Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-07-2000, 04:38 PM
Registered User
 
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
anyone have any opinions.?..I have a 1992 300SD(140) with 105k miles..Long block was replaced at 102K.The engine pulses/surges with the turn indicator and the alternator light comes on at every start up. The local MB dealer replaced a bulb in the dash(MB update I was told)..it didn't help..replaced the motor mounts...didn't help...replaced the alternator...didn't help....checked the dash cluster for shorts..none found...and btw the dash cluster was replaced in 1997....now the car is apart and they are checking wiring harnesses(and not returning my calls)I was told by the service advisor that they were having a slight problem yesterday but I would be able to pick it up today...I called three times today...and then left a message for the service manager of the dealership
All I could get was my car was in pieces because the tech had left for the day.....any ideas?....I am getting desparate...car has had almost $20K in repairs done this year(mostly warranty)

Reply With Quote
  #2  
Old 12-07-2000, 06:05 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Is the engine surging or does the tach surge?? The replacement instrument clusters require a DIFFERENT alternator on the 300SD/S350D. Red fische topic # 54T94121.
Part number of alternator is 009-154-30-02-88. Digital replacement dash isn't compatable with Original alternator.
__________________
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
  #3  
Old 12-08-2000, 08:19 AM
Registered User
 
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
Engine surge

Both the engine and tach surge.....about 500 rpm back and forth with the turn indicator...as far as I know this was the original alternator(I am not the original owner of the car. ...but interestingly enough the engine did not surge before the new long block was installed(about 2 months ago)....but the new instrument clsuter has been in the car since 1997...??

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Additives Bill Wood Mercedes-Benz Performance Paddock 6 08-24-2011 10:53 AM
Auto transmission not shifting after installation 190E Help !!!! ivanlee190e Tech Help 1 07-01-2004 08:53 PM
Engine Will not turn off. toddneeley Diesel Discussion 2 04-29-2001 12:14 AM
Slight engine surge with puls of turn indicator turnne1 Tech Help 1 11-27-2000 09:12 PM
I'm the April fool: Why can't I turn off the engine in my 240 D? Ken Diesel Discussion 5 04-01-2000 08:47 PM



All times are GMT -4. The time now is 10:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page