Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-07-2008, 06:38 PM
Registered User
 
Join Date: Feb 2000
Location: Powder Springs, Georgia, USA
Posts: 207
Intermittent A/C Compressor engagement-1985 300TD

I read a similar post for a newer model so I thought I would ask about my problem. I have a 1985 300TD. For probably the last two years my AC compressor has cycled on and off more than it should. Now it doesn't come on at all. I replaced the climate control unit some 7 years ago. The blower fan does run. Is there a relay I can check and if so where is it ? I have the CD manual but I'm not sure what to do .

__________________
David McDonald
1981 240D
1985 300D (wrecked)
1985 300TD 365,000 miles
1969 Mustang Fastback
Reply With Quote
  #2  
Old 05-07-2008, 07:31 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,548
Check to see if you are low on refrigerant.
Reply With Quote
  #3  
Old 05-07-2008, 07:59 PM
Registered User
 
Join Date: Feb 2000
Location: Powder Springs, Georgia, USA
Posts: 207
I did , so I should be good on that unless the low pressure switch is bad. Oh and I didn't say it is using R-134
__________________
David McDonald
1981 240D
1985 300D (wrecked)
1985 300TD 365,000 miles
1969 Mustang Fastback
Reply With Quote
  #4  
Old 05-08-2008, 09:06 AM
Registered User
 
Join Date: Feb 2000
Location: Powder Springs, Georgia, USA
Posts: 207
Any other ideas ?
__________________
David McDonald
1981 240D
1985 300D (wrecked)
1985 300TD 365,000 miles
1969 Mustang Fastback
Reply With Quote
  #5  
Old 05-08-2008, 10:34 AM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 5,110
Have you jumpered the low pressure switch connectors to see if the compressor clutch engages? Have you directly connected the compressor to the battery to test the clutch?
__________________
RRGrassi


70's Southern Pacific #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 297K miles

91 W124 300D Turbo replaced, Pressure W/G actuator installed. 195K

90 Dodge D250 5.9 Cummins/5 speed. 400K
Reply With Quote
  #6  
Old 05-08-2008, 04:13 PM
'79 240D
 
Join Date: Oct 2005
Location: Salem, Oregon
Posts: 15
My AC also was giving me fits; it was the clutch.
__________________
'79 MB 240D "Eres"
Reply With Quote
  #7  
Old 05-10-2008, 06:39 PM
Registered User
 
Join Date: Feb 2000
Location: Powder Springs, Georgia, USA
Posts: 207
I jumpered both switches on the drier. The aux fan ran but no joy with the AC compressor. Can the klima be bad, how can I tell. Is there a way to jumper it ?
__________________
David McDonald
1981 240D
1985 300D (wrecked)
1985 300TD 365,000 miles
1969 Mustang Fastback
Reply With Quote
  #8  
Old 05-10-2008, 07:13 PM
Registered User
 
Join Date: Feb 2000
Location: Powder Springs, Georgia, USA
Posts: 207
In another thread mdisav suggested on a different car to remove the Klima and jumper KL and 87 ( whatever those are). Well, the clutch engaged ! So I guess I need a Klima, looks like an expensive box.

__________________
David McDonald
1981 240D
1985 300D (wrecked)
1985 300TD 365,000 miles
1969 Mustang Fastback
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page