Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-08-2009, 07:16 PM
Registered User
 
Join Date: Jun 2006
Location: Scottsdale AZ
Posts: 37
SPUTTER and Hesitation

Hello,
I have a 97 E300D
I had all my plastic lines changed at about 75K with factory orings
It's now about 2 years later and I am now at 103K.
I can see air in the line that goes from the main filter to the shut off. The car hesitates a bit and sputters some times. I just got my viton oring kit from Fryer power. The lines are not clear like new, but not too bad. If I go and change all my orings over to viton, could I do it without ordering all new lines? Am I asking for trouble by not changing them?
I plan on changing all of the orings on the low pressure side of the IP. I will change the orings DV later (HP side), as they look spot less. I also got a new main filter and prefilter. Are there any things I should look out for when changing filters, or the orings on the plastic lines going into the filter? Also, when I am in there, is there a test I can do on the GLOW plugs. They were changed at 60K. The car starts perfect. The last thing I want to do is go ripping the intake off again a few weeks later.
My IP is also leaking oil from the side cover. I got the new 20$ o-ring from MB. I can't seem to locate the Torq spec for these 6 bolts on the side cover.
What is the torq spec of the hold down plate for the lines coming out of the filter? Is there a DIY write up on this topic?

Thanks
Bill
Reply With Quote
  #2  
Old 09-08-2009, 07:21 PM
babymog's Avatar
Loose Cannon - No Balls
 
Join Date: Jan 2006
Location: Northeast Indiana
Posts: 10,767
Are you running WVO?
__________________

Gone to the dark side

- Jeff
Reply With Quote
  #3  
Old 09-08-2009, 08:15 PM
Registered User
 
Join Date: Jun 2006
Location: Scottsdale AZ
Posts: 37
NOt

Running WVO because of my last episode. I bought the car with 65k. I made a trip from Phoenix to So. Cal. I stopped by a Shell station that sold B100 on the way. The car ran like a champ. Parked it at pops house and in the morning the driveway was a mess. A local Indie shop replaced all the orings and fuel lines with Stock MB parts. The car ran fine, but the smell did not go away. I removed my cover to the 6 injectors, and all the wells were plumb full. So, I bought 5 feet of MB return rubber line. All was good.
Now these days the car studders at times, and the idle is a bit rough. I can see air in line ( as they are still half clear). So, installing new o-rings, is to eliminate air. I went with the Viton so, if I ever dare that again > I wont have the same nightmare.

Bill
Reply With Quote
  #4  
Old 09-20-2009, 12:45 AM
Registered User
 
Join Date: Jun 2006
Location: Scottsdale AZ
Posts: 37
Gotta love it

All my o-rings are swapped out with Viton.
My real fix was getting my lines on the filter housing plumbed correctly.
Thanks to Terry, I got them plumbed correctly and now she is running much better?
A indie shop had crossed them.

Now she has power!!!!!!!!!!!!!!!!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page