Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Regional Forums > Pacific NorthWest -US (WA/ID/OR/UT/HI/AK)

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2021, 09:01 AM
Registered User
 
Join Date: Sep 2020
Posts: 1
1998 C280

Car turns over will not start. Replaced crank & cam sencers. Then i discovered no fuel presure. Replaced fuel pump, still no pressure. Tracked electrical line 29 from fuep pump relay to ECU, when ground pump would run. Sent ECU to repair shop. Told it was toast, had it copied on different Ecu. Installed and pump still would not run unless we put a jumper at the pump relay connection. Sent ECU back to be checked and was told it is good. Repaced relays in the trunk and under the hood that deals with the fuel system. Pump still does not run unless you use a jumper on the fuel pump relay. If i keep useing it that way it starts leaking fuel above driver's side rear wheel. I replaced the vapor pump there. My next step is to sell it as a parts car unless someone can give me a fix remedy.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:07 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page