Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 30 of 478
Search took 0.06 seconds.
Search: Posts Made By: Randy
Forum: Mercedes-Benz SL Discussion Forum 04-09-2021, 08:31 AM
Replies: 19
Views: 2,565
Posted By Randy
My Ď88 is doing this and it has a brand-new pair...

My Ď88 is doing this and it has a brand-new pair of Bosch pumps. The dying seems to be temp related.new fuel pump relay also.
Forum: Tech Help 04-08-2021, 09:37 PM
Replies: 37
Views: 2,021
Posted By Randy
I recallthat, on the Ď86 420, the ignition module...

I recallthat, on the Ď86 420, the ignition module was mounted on the steel fender liner which served as a heat sink. There was heat transfer paste between them and it was said to dry out and lose...
Forum: Mercedes-Benz SL Discussion Forum 04-08-2021, 09:20 PM
Replies: 6
Views: 486
Posted By Randy
First time. Once I got the latch tripped, just...

First time. Once I got the latch tripped, just follow the instructions.
Forum: Mercedes-Benz SL Discussion Forum 04-03-2021, 05:13 PM
Replies: 6
Views: 486
Posted By Randy
I was able to remove the hardtop today and adjust...

I was able to remove the hardtop today and adjust the cable which operates the center-rear safety latch so it will work as intended. I accomplished this by lifting the top as much as possible and...
Forum: Mercedes-Benz SL Discussion Forum 04-03-2021, 11:45 AM
Replies: 6
Views: 486
Posted By Randy
I know how to release the top and have read all...

I know how to release the top and have read all pertinent literature. Something is wrong: either the control cable is broken or is not properly adjusted.
Forum: Mercedes-Benz SL Discussion Forum 04-01-2021, 04:18 PM
Replies: 19
Views: 2,565
Posted By Randy
Min has two new Bosch pumps and does pretty-much...

Min has two new Bosch pumps and does pretty-much the same thing. I ordered a new fpr. I notice that as it progresses restarts become more difficult. Open the hood and let it cool 5 mins, and it...
Forum: Mercedes-Benz SL Discussion Forum 04-01-2021, 04:10 PM
Replies: 6
Views: 486
Posted By Randy
560 SL Hardtop Remval

What brand of explosive is recommended?
I have tried everything I have read in this Forum without success exvept to damage the finish on my 38,000 mile example.
One question: in sliding the center...
Forum: Tech Help 03-30-2021, 12:20 PM
Replies: 37
Views: 2,021
Posted By Randy
I have a new fuel accumulator to install when I...

I have a new fuel accumulator to install when I have time to do it.
One interesting thing about the run-die episodes: it involves temperature. Engine runs perfectly until it suddemly dies. Restarts...
Forum: Tech Help 03-21-2021, 06:39 PM
Replies: 37
Views: 2,021
Posted By Randy
Cold start function and repeated dying and...

Cold start function and repeated dying and dtarting, but it runs great until it starts dying suddenly
Forum: Tech Help 03-16-2021, 09:54 AM
Replies: 37
Views: 2,021
Posted By Randy
The engine started from cold but was hesitant: it...

The engine started from cold but was hesitant: it started to try to fire but required continued starter engagement to get going. It idled very slowly for 5-10 seconds then accelerated to its fast...
Forum: Tech Help 03-15-2021, 01:52 PM
Replies: 37
Views: 2,021
Posted By Randy
After about 5 miles of very nice performance and...

After about 5 miles of very nice performance and a park of 30 minutes, thecar restarted fine and after about 1 mile suddenly died: as if the key was turned off. Restarted immediately, ran about 5...
Forum: Tech Help 03-14-2021, 05:13 PM
Replies: 37
Views: 2,021
Posted By Randy
Got the 560SL running; as you said, the...

Got the 560SL running; as you said, the distributor must be in the right place. I didn’t have it close enough so I removed it and jumped the gear a couple times. Running at a fast idle 1000 rpm it is...
Forum: Tech Help 03-07-2021, 09:04 PM
Replies: 37
Views: 2,021
Posted By Randy
It has ignition; there is a fuel problem.

It has ignition; there is a fuel problem.
Forum: Tech Help 03-07-2021, 02:33 PM
Replies: 37
Views: 2,021
Posted By Randy
Point of clarification: i had the engine...

Point of clarification: i had the engine rilunning although it had at least one bad plugvwore. Had to change thecwater pump die to seal leaking; no start since.
Forum: Tech Help 03-07-2021, 02:22 PM
Replies: 37
Views: 2,021
Posted By Randy
Crank but no start. New fuel pumps. New...

Crank but no start. New fuel pumps. New plugs/wires. Proved pump relay as the pumps come on each time the key goes on. Suspect it may be the fuel accumualtor.
Forum: Tech Help 03-06-2021, 12:02 PM
Replies: 37
Views: 2,021
Posted By Randy
Hi, I have the fuel pump relay out; is there a...

Hi, I have the fuel pump relay out; is there a way to test it from the pins, as with a V-O meter?
Forum: Tech Help 02-19-2021, 09:00 AM
Replies: 37
Views: 2,021
Posted By Randy
UPDATE: I removed the fuel filter at the fuel...

UPDATE: I removed the fuel filter at the fuel distributor inlet; found nothing in the filter after some spray flushing so I put it back.
I didnít know it was there until I stumbled across a mention...
Forum: Tech Help 02-17-2021, 01:51 PM
Replies: 37
Views: 2,021
Posted By Randy
Update: There is fuel pressure at both the fuel...

Update: There is fuel pressure at both the fuel distributor inlet and the cold start richening injector, but I havenít rigged a pressure gauge as I donít want to spill gas in my garage while I have...
Forum: Tech Help 02-13-2021, 12:37 PM
Replies: 37
Views: 2,021
Posted By Randy
Thanks; did not know this.

Thanks; did not know this.
Forum: Tech Help 02-11-2021, 11:40 PM
Replies: 37
Views: 2,021
Posted By Randy
Thanks; Iíll test it tomorrow.

Thanks; Iíll test it tomorrow.
Forum: Tech Help 02-11-2021, 04:17 PM
Replies: 37
Views: 2,021
Posted By Randy
Now that I have replaced the coolant pump due to...

Now that I have replaced the coolant pump due to a leaking seal, the engine refuses to start at all. My thought is to check fuel pressure at the fuel cooler inlet; what should the pressure be?
Forum: Tech Help 02-10-2021, 03:59 PM
Replies: 2
Views: 338
Posted By Randy
Ď88 560 SL Distributor Timing

Hi, I moved my carís distributor while changing the coolant pump. I have it back in near the correct spot. What should the ignition on Cylinder 1 be on the crank dampener timing marks during...
Forum: Tech Help 02-01-2021, 06:46 PM
Replies: 37
Views: 2,021
Posted By Randy
Update: Got the engine started! It's amazing how...

Update: Got the engine started! It's amazing how much better it goes when it has GAS IN THE TANK...

Now I have to get rid of the classic 1500 rpm idle...
Forum: Tech Help 01-31-2021, 06:35 PM
Replies: 37
Views: 2,021
Posted By Randy
Update: I loosened the fuel inlet to the fuel...

Update: I loosened the fuel inlet to the fuel cooler, driverís side of the engine compartment. It wasnít dry; about a tablespoon of clean fuel dripped out but it wasnít under pressure. I connected...
Forum: Tech Help 01-31-2021, 04:05 PM
Replies: 37
Views: 2,021
Posted By Randy
560 SL UPDATE

Ignition is firing; at least it triggers my inductive timing light.
Forum: Tech Help 01-30-2021, 09:41 PM
Replies: 4
Views: 359
Posted By Randy
Thanks, great information.

Thanks, great information.
Forum: Tech Help 01-30-2021, 05:39 PM
Replies: 4
Views: 359
Posted By Randy
88 560 SL Water Pump

It seems Mercedes-Benz has discontinued this part which is surprising. Given that, is there a ďbestĒ or ďavoidĒ aftermarket brand?
Forum: Tech Help 01-29-2021, 10:59 PM
Replies: 37
Views: 2,021
Posted By Randy
No spark. Before I got the new fuel pumps, i gave...

No spark. Before I got the new fuel pumps, i gave it a shot of gas in the intake and it hit as if it had spark. Now that I have two new fuel pumps (they run at the correct time), nothing.
I did...
Forum: Mercedes-Benz SL Discussion Forum 01-26-2021, 05:53 PM
Replies: 19
Views: 2,565
Posted By Randy
Been there, got the tee-shirt. Change the...

Been there, got the tee-shirt. Change the crankshaft position sensor. On my '86 420 SEL, it was a green cable from the ignition control box, drivers' side fender well, to the bell housing.
When it...
Forum: Tech Help 01-26-2021, 05:29 PM
Replies: 37
Views: 2,021
Posted By Randy
1988 560 SL: Start After A Long Nap

Bought the above car out of an estate, 38,000 miles which various indicators say is likely correct. I know the car has sat inside a garage for years; not certain how many. It did not have bad gas in...
Showing results 1 to 30 of 478

 
Forum Jump


All times are GMT -4. The time now is 03:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page