Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Search Forums

Showing results 1 to 7 of 7
Search took 0.01 seconds.
Search: Posts Made By: Phillip Jones
Forum: Tech Help 02-02-2019, 10:53 AM
Replies: 15
Views: 1,037
Posted By Phillip Jones
brand new battery in trunk and auxilary one as...

brand new battery in trunk and auxilary one as well. Both holding full charge. I am going back thru the fuses and relays making sure that everything is asleep. I have determined it is for sure not...
Forum: Tech Help 02-01-2019, 12:58 PM
Replies: 15
Views: 1,037
Posted By Phillip Jones
After giving everything time to go to sleep i am...

After giving everything time to go to sleep i am getting a .15 amp draw. I disconnected the alternator but the draw is still there. Is that enough to kill the battery overnight?
Forum: Tech Help 01-31-2019, 01:59 PM
Replies: 15
Views: 1,037
Posted By Phillip Jones
i have been getting a message that my teleaid was...

i have been getting a message that my teleaid was defective. But it has done that since i bought the car a year ago. and only a month ago did it start this discharge problem. A mechanic told me that...
Forum: Tech Help 01-30-2019, 09:47 PM
Replies: 15
Views: 1,037
Posted By Phillip Jones
ok i remember there is a terminal block near the...

ok i remember there is a terminal block near the battery which has 4 leads if i remember correctly, not sure which one is the alternator but i can try all 4 and see if the leakage goes away, thanks...
Forum: Tech Help 01-30-2019, 07:37 PM
Replies: 15
Views: 1,037
Posted By Phillip Jones
can i get to the connection to disconnect from...

can i get to the connection to disconnect from the engine bay or am i going to have to jack the car up to get to it?
Forum: Tech Help 01-30-2019, 06:24 PM
Replies: 15
Views: 1,037
Posted By Phillip Jones
Ok thanks i will check that next. I just went...

Ok thanks i will check that next. I just went back thru every fuse and relay just to make sure. Still getting a drain, sometimes only about .4amps, sometimes as much as 2.5.
Forum: Tech Help 01-30-2019, 04:07 PM
Replies: 15
Views: 1,037
Posted By Phillip Jones
E500 battery discharge problem

I am chasing a battery discharge problem on my 2003 E500. I have disconnected the power seat modules and the audio gateway. I bought a low current amp probe and i am getting anywhere from a 1.5 to a...
Showing results 1 to 7 of 7

 
Forum Jump


All times are GMT -4. The time now is 02:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page