PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/index.php)
-   Tech Help (http://www.peachparts.com/shopforum/forumdisplay.php?f=1)
-   -   W124 A/C Trouble (http://www.peachparts.com/shopforum/showthread.php?t=280499)

PhantomLord 07-05-2010 02:36 AM

W124 A/C Trouble
 
My W124 E220 seems to have A/C trouble since past 15 days. Sometimes A/C does not blow cold when switched on, it automatically starts blowing cold after sometime(If I press defogger button, A/C seems blow cold air bit earlier), but the temperature control does not work when this happens. Irrespective of temperature control position it keep blowing cold air, if i set the temperature setting to full hot with a click it starts blowing hot.

What should I check?


Thanks

1stimer 07-05-2010 01:34 PM

Maybe your aspirator blower or cabin temp sensor?

LarryBible 07-05-2010 07:40 PM

Yes, the sample blower that pulls air through the small grille near the rear view mirror. The blower was in a number of different locations during the 124 production run.

To check it, cut a 1 centimeter square piece of paper and hold it to the little grille with the key on. If the paper stays in place the sample blower is working. If not, find the blower, check it for voltage and if it has voltage and not running, replace it.


All times are GMT -4. The time now is 09:54 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website