PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/index.php)
-   Tech Help (http://www.peachparts.com/shopforum/forumdisplay.php?f=1)
-   -   Noise from instrument cluster (http://www.peachparts.com/shopforum/showthread.php?t=43748)

190dee 08-08-2002 01:48 PM

Noise from instrument cluster
 
Ok...this is not the season but IMO it would be nice to correct this before next winter. The noise only generates when wheather is -10 degrees CELSIUS or more

What I can understand it must be the speedometers machinery that makes this noise. It's not ticking or anything. It's more like one tone noise that yells out loud. It starts a about 50 km/h. When speed changes above 80 km/h the pitch of the noise raises and keep the same until 110 km/h. Then the pitch is raised again. It is very loud this noise and irritating :(

Is there some kind of grease or similar to apply to the speedometer. Anyone else experienced this? Is it possible to open the speedometer?

Hope I'm not the only one that has cold winter:(

JOHNSC16V 08-08-2002 07:40 PM

I don't know if this help, but it might be your speedocable! It might need couple drops of ATF oils...but not too much!!

john

190dee 08-09-2002 02:29 PM

I will also try this at the same time but I am quite sure it is the gears inside the speedo that's making this noise.

Thanks for you suggestion.


All times are GMT -4. The time now is 06:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website