PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/index.php)
-   Tech Help (http://www.peachparts.com/shopforum/forumdisplay.php?f=1)
-   -   420SEL A/C don't work (http://www.peachparts.com/shopforum/showthread.php?t=6528)

rudy 02-29-2000 05:29 AM

Recently, the mechanic replaced the evap fan, had the unit recharge with freon, ..but after a week, the a/c did'nt work anymore. It seems that the comp does not activate when the normal switch is pushed. Do I have any problem with the climate control knob ? Where is the relay that activate this unit ?Also, ..I notice that the clock does not perform correctly, ..most of the time, ..it's fast. Please provide some tech advice.

Ron Zarantenello 02-29-2000 09:50 AM

My '86 420SEL was fully charged with freon and still didn't operate. The problem was the push-button assembly. If all other parts of the AC system check out fine, then your buttons may be the culprit. I was able to order a rebuilt part over the Internet for a mere $150 and install it in 45 minutes. If you've never taken the wood fascia off your console before, then I suggest having a pro do the work as there are many, many connectors and fiber optic lines that must be taken apart carefully. But the procedure is rather simple. Good luck.

------------------
Current: '86 420SEL, '81 380SL
Previous: '79 240D, '70 280SE, '81 300D.
Just about 600,000 miles on Mercedes products.

rudy 02-29-2000 10:52 AM

Ron, ..thanks for tech info. Will try and see if I can investigate every switch that this control panel has, ...also, would you mind to know why the auxiliary fan never activates at any given temp ? where the switch for that ? Is this controlled by the climate control knob ? Was there there any way to bypass this set up ?

Benzmac 02-29-2000 09:02 PM

The quick way to check to see if it is a freon problem is to bridge the low pressure switch on the drier and turn on the a/c. If the compressor turns on, you are low on refrigerant.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM



roberth 02-29-2000 11:31 PM

Benzmac,

Or you have a bad low pressure switch :-)

Robert

rudy 03-02-2000 04:17 AM

Benzmac, ...Robert, ...thanks for the help. I did bridge the low pressure switch and notice that the condenser fan runs continuosly, ...comp kicks in but its not getting cold enough within specs. I was lucky to find a NEW low pressure switch but was scared to remove the old one. Will this release all the freon in the system if the old switch be disconnected. Any idea please ?....


All times are GMT -4. The time now is 12:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website