PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/index.php)
-   Tech Help (http://www.peachparts.com/shopforum/forumdisplay.php?f=1)
-   -   W123 A/C will not work (http://www.peachparts.com/shopforum/showthread.php?t=7466)

DeltaDave 05-10-2000 01:14 PM

I have a 1985 300TD and the Climate Control will not work ( no defrost, heat, or A/C)when the outside air temp is very warm or hot. When it cools off in evenings or morning it works fine. I have the CD, any suggestions where to start ?

Alec 05-10-2000 04:26 PM

I have an 85 300TDT and I noticed that the controls for the A/C, heat, etc were all not working or at least nothing was coming on when I pushed the buttons. As it turns out the ignition switch was loose and the power to the climate controls being cut off. This may not have anything to do with your problem but this was causing intermittent disfunction. All I have to do is move the key slightly while the car is still running and I can hear a click...the power is restored. I need to take the ignition switch out and see wha tI can do to improve the connections. Go figure.

Alec.

LarryBible 05-10-2000 05:17 PM

Folks,

I recently bought an '81 300D for my daughter. You had to turn the ignition switch slightly counterclockwise after starting to make the climate control system work. I replaced the ignition switch for about $16 and the problem went away.

Remove the instrument cluster to get to the electrical switch which is screwed to the back of the lock mechanism with three screws. Wiggle your switch and see if this is your problem, if so it's an easy fix.

Good luck,

------------------
Larry Bible
'84 Euro 240D, 516K miles
'88 300E 5 Speed
'81 300D Daughter's Car
Over 800,000 miles in
Mercedes automobiles

Benzmac 05-10-2000 08:20 PM

You may be a little low on freon...Have it checked.

------------------
Benzmac:
Donnie Drummonds
1992 500E (very soon I hope :)
1981 280GE SWB
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM

DeltaDave 05-12-2000 12:56 PM

Thanks ! It was the switch ! I guess I'll get it fixed one of these days. Right now it's OK.


All times are GMT -4. The time now is 05:03 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website