PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/index.php)
-   Tech Help (http://www.peachparts.com/shopforum/forumdisplay.php?f=1)
-   -   Have to Acknowledge Phil at PartsShop, and Share a Radiator Repair (http://www.peachparts.com/shopforum/showthread.php?t=92080)

JimSmith 04-17-2004 09:19 PM

Have to Acknowledge Phil at PartsShop, and Share a Radiator Repair
 
First, I have to relate how Phil from the PartsShop went way out of his way to help me out. My daughter has a 1986 190E 2.3-16 we picked up on eBay last summer, and we have been fixing various items ever since. The latest turned out to be badly worn distributor cap, rotor and burned out wires. I discovered this was the problem examining a different problem (radiator neck broken) when, at about dusk I put my hand on the hose from the radiator to the thermostat housing with the car idling (poorly) and got a good zap from the ignition wires. Looking closer I saw there was a steady flow of fine bluish high voltage leakage "threads" all around the distributor cap.

Went to take the cap off and check the situation out inside there and found the aft screw holding the cap on was not coming out. After a number of days struggling with this (while working on the radiator problem), soaking it in penetrant, etc. and making ever more forceful attempts to get it off, I finally broke the aluminum distributor casting by smacking the fastener with an impact driver. Not a good idea.

I called Phil, and he found me a used on for a fraction of the cost of a new one within a few minutes, and I ordered new plugs, wires, distributor cap and rotor along with the replacement distributor. There are two rotor models listed and which one you use depends on the distributor serial number you have. The "new" distributor serial number indicated it would need a particular rotor, and Phil shipped it to me. All the stuff showed up on Friday, and at about 5 pm I went out to take care of my earlier stroke of brainlessness.

Job was done in 20 minutes, with 18 of them spent cleaning the area before opening it up, lubricating the threaded holes with anti-sieze and so on. When I went to put the rotor on it did not fit. By this time on a Friday, Phil was gone for the weekend, but his answering machine suggests you leave him a message, which I did. I noted the rest of the stuff worked great, and unfortunately, at this time of day when I found out I had a problem, he and the local dealer's parts counter was closed. I was resigned to dressing up the old rotor on Saturday to make sure the car would run, but mainly to test the radiator fix.

I got a phone call about 6:30 pm - Phil noted he got my message and a new rotor was on its way, FedEx, Saturday delivery. It was from another parts source Phil cooperates with, and sure enough, at 10:00 a.m. the box arrived. Car is running great again, daughter is very happy and so am I. Just had to relate a great experience.

Now to the radiator fix. Daughter called one night about a week ago and said the radiator hose had popped off and shot coolant all over the engine. She managed to not overheat anything, and did not loose the clamps, so I talked her through getting it back on, filling the system up with coolant and driving home with the expansion tank pressure cap off to avoid pressurizing the system and forcing the hose off again. When I saw what had happened, I recalled reading about this here before - the plastic connection for the hose broke right off (my daughter said the pieces came out of the hose in her hand) and left only about an inch of nipple to slip the hose over.

I went to Home Depot and found a couple of plumbing fittings (part of a mechanical copper union, and then a 1" to 3/4" copper adapter) that, when fit together (one slipped mostly inside the other), formed a good two inch long nipple with a suitable ridge for the hose to clamp on, and a reasonably tight fit inside the broken off nipple stub. I soldered the copper parts together and then JB Welded the soldered assembly into the stubby radiator nipple. It has been running fine for a day now, and shows no signs of distress, yet. I will let you all know if it fails, but the total cost was about $4.50 for the parts and a few more bucks for the JB Weld. I thought it was worth a try, instead of buying a new radiator.

I took some photos and can get the part numbers of the Home Depot parts if anyone is interested. Jim

grimgaunt 04-18-2004 12:52 AM

radiator fix
 
I did the same thing 2 yrs ago, has held on and since then have sold the car and saw it recently at a store. Owner said it was fine.

BobK 04-18-2004 06:55 PM

Was there green or red antifreeze in that radiator? Been hearing enough to suspect that green (non-MB) antifreeze speeds up the failure. That's what was in two of mine when they failed. Thermostat cover died too on the 124. So far, I haven't had to pay too much for a radiator.

JimSmith 04-18-2004 07:24 PM

BobK,

You may have a point. The car had the green stuff in it. So did the W124 300E when the thermostat housing nipple failed. You may have a point. Thanks, Jim

PaulH 04-18-2004 11:08 PM

There are other threads that have come up with the same conclusion. I have not (yet) had the problem, but only MB coolant has been used in my old SDL ever since it was new.

psfred 04-18-2004 11:23 PM

The phosphates in the green coolant (or whatever is in there) appear to degrade the plastic badly. I've seen a couple failures, and have also found that when the hose nipple goes, the rest of the rad is ready for the trash, too.

Usually full of corrosion, and both tanks are very brittle.

Best to bite the bullet and put a new rad in BEFORE it blows and overheats.

Peter


All times are GMT -4. The time now is 02:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website