Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Vintage Mercedes Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-07-2021, 02:40 PM
Registered User
 
Join Date: Oct 2012
Posts: 15,843
Becker push buttons will not pull out....

This might need to be in the radio forum, but I looked there and could not find anything on Beckers from the 70s.

I have a normal Becker Europa from the late 60s or early 70s and the buttons will not pull out so I can reset the stations. The buttons push in OK and move the needle and change the stations. But they will not pull out to reset the station preset.

I have looked this pushbutton assembly over and cleaned and oiled everything I can find that looks like it might move. This gave the radio a nice feel when tuning as must have put the feeling back to where the radio was when new.

But the push buttons will still not pull out to allow for reseting.

Can anyone tell me where the hang up might be?

By the way, this is on all five buttons. So whatever it is is a problem that might have a single solution, a single point that is not moving like it should.

Any guesses?

Reply With Quote
  #2  
Old 03-07-2021, 10:55 PM
280EZRider's Avatar
No Dumping
 
Join Date: Jul 2007
Location: Southern Oregon Valley
Posts: 1,544
Does the button that is currently set to a station snap out of its set position once a different station is selected? This position should then be the same as the other buttons and not to farthest position for changing station-to-button settings.
__________________

Don't Chrome them; polish them
Reply With Quote
  #3  
Old 03-08-2021, 01:35 PM
Registered User
 
Join Date: Oct 2012
Posts: 15,843
Yup. All the buttons work to change stations. That is, wherever they are set now they will go to with no trouble at all.

But if I tune to another station, and wish to pull out the button to set that button to that station, then the buttons will not pull out.

I have looked at the entire assembly through a magnifying glass and I can't see where anything is hanging up but something has to be. I can understand that the same thing might be hanging on all five of the different buttons. I just can't figure out what that thing is in order to free it.
Reply With Quote
  #4  
Old 03-08-2021, 10:06 PM
280EZRider's Avatar
No Dumping
 
Join Date: Jul 2007
Location: Southern Oregon Valley
Posts: 1,544
When changing stations the button pulls out only about 3/8 inch beyond the adjoining buttons. Then it is pushed in very deep to actually set the station. I wonder if this short movement is being mistaken as not pulling out.
__________________

Don't Chrome them; polish them
Reply With Quote
  #5  
Old 03-09-2021, 02:38 PM
Registered User
 
Join Date: Oct 2012
Posts: 15,843
Nope. They return to their normal position after being pushed. I have had a number of these radios before but I have never run into this problem.

This may be more than I can deal with since it appears there is something inside the 'posts' that is the cause of the hang-up.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page