PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Diesel Discussion (http://www.peachparts.com/shopforum/diesel-discussion/)
-   -   Kaehler wiper relay (http://www.peachparts.com/shopforum/diesel-discussion/251688-kaehler-wiper-relay.html)

apsaulters 05-02-2009 05:58 PM

Kaehler wiper relay
 
2 Attachment(s)
Since last November, the wipers will only work on the fastest speed. I replaced the wiper relay, which looked like the one highlighted in the second picture: wide, flat metallic case; seven pins. I replaced it because I heard a clicking coming from it each time I turned on the intermittent wipers. I got it from the dealer because I could not find it online. This did not fix the problem, nor did replacing the fuse for the wipers.

When I looked for a wiper relay online, every parts store suggests the one in the first picture: a tall, skinny plastic relay manufactured by KAE. I cannot find where such a relay would go on my car (1978 240D). Does the KAE relay fit the 1978 240D? Where does it install? Thanks in advance for any help.

techguy512 05-02-2009 07:12 PM

Quote:

Originally Posted by apsaulters (Post 2190315)
I replaced the wiper relay, which looked like the one highlighted in the second picture: wide, flat metallic case; seven pins.

There were two styles of pulse wiper relay, I call them the "old" and the "new". The old was larger, aluminum case relay, and the new is the smaller, plastic case relay currently sold by all the parts places. They function identically, but mount into different sockets. If your car is a '78, you will undoubtedly use the "old" style.


Quote:

Originally Posted by apsaulters (Post 2190315)
I replaced it because I heard a clicking coming from it each time I turned on the intermittent wipers.

This is normal. The clicking is the electronic relay engaging and disengaging.


Quote:

Originally Posted by apsaulters (Post 2190315)
Since last November, the wipers will only work on the fastest speed.

Your problem is most likely in the wiper switch, motor or wiring, as the pulse wiper relay is only involved in the intermittent function and the "wipe after wash" function.

Diz 05-17-2009 09:09 AM

I have a 95 S320 that is doing the same thing...wiper works on high and not intermittent or low. Question is does the W140 series wipers work the same, ie don't bother with the relay- replace the motor or the switch? thanks John

apsaulters 05-17-2009 11:49 AM

I'm not sure about the w140, but replacing the combination switch solved my problem.


All times are GMT -4. The time now is 02:51 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website