Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > SL Forum

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-13-2006, 01:22 PM
Registered User
 
Join Date: Oct 2005
Posts: 3
500SL problems!!!

I have a 1991 500SL that is having some trouble with the top and roll bar. The switch for the top does not work, I have tried to pull the codes but there is no blinking at all. Even when I try to more the switch back and forth there is no light at all. I have tried to hold the switch for more than 5 seconds but still no response. I have also tried to read the codes from the diagnostic port using a switch and an LED. Also the roll bar is in the up position even though the hard top is on.

What are the most common components to go relating to my problem?

Thank you for your time.
Reply With Quote
  #2  
Old 10-13-2006, 10:43 PM
waybomb's Avatar
Registered User
 
Join Date: Nov 2002
Location: St. Joe, MI; Manitowoc, WI
Posts: 1,553
Is it even getting power? Rotate all your fuses in their holders. May just be a bad connection.
__________________
Thank You!
Fred
2001 E430 Sport, 204,000 miles
1997 C280 Sport, 144,000 miles
1991 300SL, 189,000 miles
1987 420SEL, 149,000 miles
1986 190e 2.3 16v, 151,000
1968 W30 442, 78,000 miles
1988 46' US1 Cougar, 3 supercharged 572's
http://s4.photobucket.com/albums/y145/waybomb/
Warming the globe, 24 cylinders at a time
And I want a 126 wagon! Point me to one!
Reply With Quote
  #3  
Old 10-14-2006, 12:47 AM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,149
Do the windows work OK? Do you have 12 volts on pin 16 of the diagnostic port? The top and bar controller is under the right rear storage compartment. Can you hear the relays click when you activate the windows or the top switch? Since even the lamp in the top switch doesn't light, you may, as stated above, have a bad fuse. Don't just look at them; measure them with a meter. The old aluminum fuses corrode and look OK, but don't work. There is a brass fuse upgrade kit available. Rarely does the controller go bad. Usual problems are fuses, limit switches and bad connections.
__________________
Resistance is Futile.
Reply With Quote
  #4  
Old 11-01-2006, 01:19 AM
Registered User
 
Join Date: Aug 2006
Posts: 26
Question

Did you intentionally leave your roll bar up ?

If not, it may have been deployed as a result of excessive suspension drop (going over a bump) causing the car to think it was rolling over.

If that's the case, the rollbar has to be reset before the top will operate.
__________________
1998 SL 500 Sport (Samantha)
2005 E 55 AMG (Dr. Jekyl)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page