Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-15-2006, 07:00 PM
dmorrison's Avatar
Registered User
 
Join Date: Dec 2002
Location: Colleyville, Texas
Posts: 2,695
AC compressor noise. 1983 240D

Many little things are happening to the car this summer, 1983 240D. New tires promted a front end alignment. Adjusted the steering box due to "wondering after the new tires, it was just the alignment so I had to adjust the steering box again.
Water pump started leaking and I did not catch the puddle under the car so it over heated on the highway. Had it towed and I replace the water pump ( running fine now) . Shortly after that, a noise started in the front of the engine. Though maybe the timing chain but diagnosed it today to the AC compressor. Occurs only with the AC on. The noise is the sound of a couple of marbles loose. Sort of a random pattern and only at idle. Rev the engine and it stops. AC pressures are normal for todays temperature. I added 2 oz of mineral oil. Still there. Does not occur when the clutch is disengaged. AC is cold. Vent temps normal.
Last December I replaced the evaporator due to a leak. New R/D, oil for the Evaporator, expansion valve. Flushed all lines and condensor. And now this noise.

Anyone heard this "noise". It is possible the compressor is failing. Don't need that right now. Pressures were 22 Low and 295 High. 95 degrees today.
Vent temps 38.

Thanks for the input.

Dave

__________________
1970 220D, owned 1980-1990
1980 240D, owned 1990-1992
1982 300TD, owned 1992-1993
1986 300SDL, owned 1993-2004
1999 E300, owned 1999-2003
1982 300TD, 213,880mi, owned since Nov 18, 1991- Aug 4, 2010 SOLD
1988 560SL, 100,000mi, owned since 1995
1965 Mustang Fastback Mileage Unknown(My sons)
1983 240D, 176,000mi (My daughers) owned since 2004
2007 Honda Accord EX-L I4 auto, the new daily driver
1985 300D 264,000mi Son's new daily driver.(sold)
2008 Hyundai Tiberon. Daughters new car
Reply With Quote
  #2  
Old 06-15-2006, 07:08 PM
Registered User
 
Join Date: Sep 2004
Posts: 8,820
I can't explain why, but a loose drive belt will cause a compressor to make those kinds of noises. Mine did the same thing. When I bought a NAPA Kriket belt tension guage and adjusted the belt tension to spec, the noise stopped.
Reply With Quote
  #3  
Old 07-10-2006, 08:47 PM
Registered User
 
Join Date: Apr 2005
Location: Austin, TX
Posts: 631
Quote:
Originally Posted by dmorrison
Occurs only with the AC on. The noise is the sound of a couple of marbles loose.
Did you ever resolve this? I have the same noise. 2 marbles loose, or a 3 legged horse walking on cobblestones. Only at idle.

New compressor. New R/D, expansion valve, condenser, a few new hoses, 170 ml mineral oil, 2.6 lbs R-12.
Reply With Quote
  #4  
Old 07-11-2006, 06:21 PM
KCM KCM is offline
Registered User
 
Join Date: Jan 2004
Posts: 640
I second a loose belt as the cause. The compressor on my 300 started making this god awful noise at idle, as if the compressor was grinding it's inner workings. Tightened the belt and it was quiet again. Mercedes should have used two belts instead of one on the A/C in my opinion.
Reply With Quote
  #5  
Old 07-11-2006, 06:34 PM
Registered User
 
Join Date: Apr 2005
Location: Austin, TX
Posts: 631
Well, I bought a kricket tension gauge this afternoon. We
will see if belt tension is the cause.
Reply With Quote
  #6  
Old 07-11-2006, 09:10 PM
Registered User
 
Join Date: Apr 2005
Location: Austin, TX
Posts: 631
Quote:
Originally Posted by techguy512
We will see if belt tension is the cause.
All belts were dangerously loose. So much for tensioning belts by "feel".

My Haynes manual was practically useless. It said tension for
A/C and P/S was '50'. Can't be kg, must be pounds. Set both at 50 pounds.

It said the alt belts should be '30'. I couldn't get them equal, so the inner
is at 30 lbs and the outer ended up at about 25.

Most importantly, the noise is gone. Thanks everyone.
Reply With Quote
  #7  
Old 07-11-2006, 09:47 PM
Senior Member
 
Join Date: Feb 2001
Location: Canton,Texas
Posts: 987
You might want to check the bolts that hold the compressor on too..... I would even if the noise is gone, you don't want to loose one of them (not easy to find another).
__________________
1985 300D Turbo ~225k
2000 F350 (Powerstroke) 4X4, SWB, CC, SRW, 6spd ~148k
1999 International 4900, DT466e (250hp/660 ft/lbs), Allison MD3060 ~73k
Reply With Quote
  #8  
Old 07-11-2006, 10:11 PM
Registered User
 
Join Date: Apr 2005
Location: Austin, TX
Posts: 631
Quote:
Originally Posted by Wasuchi
You might want to check the bolts that hold the compressor on too.....
Retorquing the compressor attach bolts was part of the belt
tensioning exercise. They are all torqued properly.
Reply With Quote
  #9  
Old 07-12-2006, 02:55 AM
dmorrison's Avatar
Registered User
 
Join Date: Dec 2002
Location: Colleyville, Texas
Posts: 2,695
To close this post.

I installed 2 oz of AC Mineral oil. Check the charge and added a couple of OZ of R12. Based on the outside temp. Installed a new AC and power steering pump belt due to the power steering belt separating. And the sound is gone. Or at least my Daughter has not mentioned it. And yes, she mentions every little noise in the car. To the point that I tell her to turn up the stereo. I am assuming it was the Mineral oil or probably the belt.

Just wanted to complete the post.

Dave

__________________
1970 220D, owned 1980-1990
1980 240D, owned 1990-1992
1982 300TD, owned 1992-1993
1986 300SDL, owned 1993-2004
1999 E300, owned 1999-2003
1982 300TD, 213,880mi, owned since Nov 18, 1991- Aug 4, 2010 SOLD
1988 560SL, 100,000mi, owned since 1995
1965 Mustang Fastback Mileage Unknown(My sons)
1983 240D, 176,000mi (My daughers) owned since 2004
2007 Honda Accord EX-L I4 auto, the new daily driver
1985 300D 264,000mi Son's new daily driver.(sold)
2008 Hyundai Tiberon. Daughters new car
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page