Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-26-2008, 07:28 PM
Registered User
 
Join Date: Dec 2006
Location: Eastern Mass
Posts: 231
B2 problem?

Almost got stuck in Maine today after taking a ride up to Freeport. When leaving the tranny slipped like crazy in 1st and 2nd. Once moving it seemed OK. I think 3rd & 4th feel good w/o slipping. I managed to get home (130miles)without having to stop much. Prior to this there was no issue other than some flaring once in a while. At home now it does not want to move much in forward. I checked the fluid level and it seems fine. Also I had replaced the fluid and filter about 40K ago.
Does this seem like a B2 issue? or could it be some other problem. I am hoping I don't need to do major work on the tansmission now.
If it is B2 where is the best place for parts? Also should I do the K1 upgrade as well at the same time?

__________________
81 300D Turbo 190K sold
83 300sd 319K best $500 I ever spent-daily driverw/ 2 tank WVO set up
Reply With Quote
  #2  
Old 12-26-2008, 09:42 PM
81300sd's Avatar
Registered User
 
Join Date: May 2008
Location: Spokane WA
Posts: 312
Sounds just like the B2 piston. There is cheaper places but I got mine from the dealer. It is a good time to do K1 as you will have the pan off and fluid drained already.

You will need B2 piston, bushing, and seal. Fastlane has good prices on these parts and supports this forum.
__________________
81 300SD daily driver/project
86 420SEL (sold)
85 380SE(in the graveyard)
Reply With Quote
  #3  
Old 12-27-2008, 07:19 AM
Registered User
 
Join Date: May 2001
Location: Michigan
Posts: 1,373
I've had the problem twice, but never done the B-2. Opted for tranny swaps both times as I had a couple on hand.

Your assessment sounds accurate however. In one situation I had gradual flaring and in the other ..... boom! Just happened overnight.
__________________
DAILY DRIVERS:
'84 300DT 298k (Aubrey's)
'99.5 Jetta TDI IV 251k (Julie's)
'97 Jetta TDI 127k (Amber's)
'97 Jetta TDI 186k (Matt's)
'96 Passat TDI 237k (Don's
'84 300D 211k Mint (Arne- Undergoing Greasecar Conversion)

SOLD:
'82 240D 229k (Matt's - Converted-300DT w/ 4 speed
Reply With Quote
  #4  
Old 12-27-2008, 09:58 AM
930dreamer's Avatar
Registered User
 
Join Date: Aug 2008
Location: Amarillo, TX
Posts: 127
I would be very interested to hear if the B-2 fixed your shifting issues. My 86 SDL won't shift into 4th. Shawn
Reply With Quote
  #5  
Old 12-27-2008, 12:06 PM
Registered User
 
Join Date: Dec 2006
Location: Eastern Mass
Posts: 231
I ordered the parts from Fastlane this morning. I will probably open it up tommorrow to see what it looks like-luckily it should be relatively warm-50s.
Does anyone know the part # for the k1 kit? I couldn't find it on Fastlane.
__________________
81 300D Turbo 190K sold
83 300sd 319K best $500 I ever spent-daily driverw/ 2 tank WVO set up
Reply With Quote
  #6  
Old 12-27-2008, 12:51 PM
Registered User
 
Join Date: Sep 2004
Posts: 8,830
Quote:
Originally Posted by paulc66t View Post
does anyone know the part # for the k1 kit?
126 270 44 77
Reply With Quote
  #7  
Old 12-27-2008, 01:01 PM
81300sd's Avatar
Registered User
 
Join Date: May 2008
Location: Spokane WA
Posts: 312
Quote:
Originally Posted by 930dreamer View Post
I would be very interested to hear if the B-2 fixed your shifting issues. My 86 SDL won't shift into 4th. Shawn
B2 has nothing to do with 4th gear. 1st and 2nd only.
__________________
81 300SD daily driver/project
86 420SEL (sold)
85 380SE(in the graveyard)
Reply With Quote
  #8  
Old 12-27-2008, 01:11 PM
81300sd's Avatar
Registered User
 
Join Date: May 2008
Location: Spokane WA
Posts: 312
Quote:
Originally Posted by Paulc66t View Post
I ordered the parts from Fastlane this morning. I will probably open it up tommorrow to see what it looks like-luckily it should be relatively warm-50s.
Does anyone know the part # for the k1 kit? I couldn't find it on Fastlane.

Make sure you have the seal that goes with it as well. I have not been able to find it in any of the parts suppliers online. They probably all have it and not listed. You will destroy the seal getting it out and its plenty old enough anyway to justify replacing.

BTW the easiest way of getting that sleeve and seal out is by pulling the valve body and plate and pushing it out from the inside. Don't be afraid of this as you are just removing the entire unit, not any internals.


http://www.dieselgiant.com/Mercedesb2pistonsealreplacementl.htm

10th picture from the bottom is the seal and sleeve. You will be replacing that sleeve with a teflon sleeve, the metal sleeve is part of the problem and the piston is the other part of the problem.

__________________
81 300SD daily driver/project
86 420SEL (sold)
85 380SE(in the graveyard)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page