Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > ML, GL, G-Wagen, R-Class, Unimog, Sprinter

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-17-2021, 11:09 AM
Registered User
 
Join Date: Oct 2007
Location: NJ
Posts: 121
Ml320 2001 has limp mode and shifter will not work

So the shifter will not go from drive to park stops at neutral.When I tun the key to off will go to park.When I place my foot on the brake and shift to drive it clunks badly and will not go to park.When I push the brake pedal I hear the relay clicking,except I have no indication on the dash of what gear,blanked out.Also when I take the brake out of the issue by placing the emergency brake on and key on shifts normal no clunking.Touch the brake pedal and it won’t shift.Brake interlock solenoid?Brake switch? Or shifter ? Any help with this issue appreciated.


Last edited by Devil Dog; 04-17-2021 at 11:31 AM.
Reply With Quote
  #2  
Old 04-18-2021, 10:01 AM
ILUVMILS's Avatar
Senior Member
 
Join Date: Sep 2002
Posts: 2,898
The blank shift indicator usually means the shifter is faulty. Make sure you have power and ground to the shifter.
Reply With Quote
  #3  
Old 04-20-2021, 03:25 PM
Registered User
 
Join Date: Oct 2007
Location: NJ
Posts: 121
I have a read out from scanner shifter implausible also changed the brake switch.With the engine running and trying to shift its nasty clucking and surges.Brake not applied smooth and no noise?I r&r’d the brake switch no help.I’m going to remove the shifter now
Thanks
Reply With Quote
  #4  
Old 04-20-2021, 09:48 PM
Registered User
 
Join Date: Oct 2007
Location: NJ
Posts: 121
Ok up date the shifter was removed.The actuator relay is not working properly was corroded around the plunger cleaned all parts lubricated all parts with moly grease.I think the shifter plates had some kind of Teflon applied which is worn off or disintegrated.Plunger doesn’t appear to engage or die gauge properly......New shifter wish I could rebuild it.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page