Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-05-2004, 10:43 AM
Registered User
 
Join Date: Nov 1999
Location: Lynnwood, WA, USA
Posts: 178
Vacuum Pump

I am trying to determine if the vacuum pump in my 84' 500SEL is defective or not. The pump only works when I disconnect then connect the electric plug on the pump itself. Then it will work for a short period (a few hours) when I use my door key, after that it stops working again until I disconnect the plug at the vacuum pump again.

Tommy

Reply With Quote
  #2  
Old 09-06-2004, 02:01 PM
Registered User
 
Join Date: Jul 2000
Posts: 638
84 500 vac pump

It could be the door switch itself or the connection there. The vac pump has to run long enough to 'switch over' (complete an open or close cycle and turn off) or it will sit there and play dead until its disconnected.

Try getting it working and run several cycles of lock/unlock using the key in the door and see what happens.

If these is a leak in the vacuum plumbing, the pump will not build up enough pressure to switch over to the other cycle. It will run until the relay timer shuts it off and then just sit there.
Reply With Quote
  #3  
Old 09-06-2004, 06:02 PM
Registered User
 
Join Date: Nov 1999
Location: Lynnwood, WA, USA
Posts: 178
Thank you for your reply. I have tried many times with the key locking and unlocking the door, and (when the pump is working) it worked everytime. I am fairing sure that the door switch is okay. There doesn't seem to be any leak in the system as all the locks operated very quickly. I think, for some reasons, the pump is working intermitently. Anyway, I found a good deal on a new pump so I am crossing my fingers that it will solve the problem.

Thanks.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page