Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-10-2005, 01:56 PM
Registered User
 
Join Date: Sep 2005
Posts: 4
1993 400SEL a/c issue

Upon cold start, a/c blows cold. After driving and engine comes up to temp, it blows hot air. Freon charge is full. But compressor doesnt come on.

Any suggestions for relay switch check or Klima?

Many thanks

Reply With Quote
  #2  
Old 09-10-2005, 05:10 PM
Member
 
Join Date: Jan 2003
Location: Florida
Posts: 1,084
Just maybe

I have had a similar problem, turn off the igniton and restart. If it comes back you have a slipping belt, It seems they had a sensor in the compressor that compared it to engine speed. I drove me crazy, I would accelerate hard and the AC would quit, or drive thru a puddle, MB replaced belt amd tensioner. The issue is gone and has been gone for two years.
Reply With Quote
  #3  
Old 09-10-2005, 08:19 PM
Registered User
 
Join Date: Sep 2005
Posts: 4
Thanks!
Quote:
Originally Posted by Peter Guenther
I have had a similar problem, turn off the igniton and restart. If it comes back you have a slipping belt, It seems they had a sensor in the compressor that compared it to engine speed. I drove me crazy, I would accelerate hard and the AC would quit, or drive thru a puddle, MB replaced belt amd tensioner. The issue is gone and has been gone for two years.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
91 300E ABS Light Came On, A/C Blower Slowed gmercoleza Tech Help 15 01-28-2019 09:52 PM
1993 500SL Central Locking Pump / Locking issue MJM Mercedes-Benz SL Discussion Forum 7 04-30-2006 05:18 AM
Trying to diagnose A/C system josetann Diesel Discussion 6 05-24-2005 08:40 AM
W124 A/C after a few hours driving Q-Ball Tech Help 25 07-11-2004 03:42 PM
190/16 Valve A/C and Engine Idle Stability Is Intermittent JimSmith Tech Help 5 08-13-2001 05:15 PM



All times are GMT -4. The time now is 09:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page