Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-12-2009, 01:21 PM
08 C300 4matic, 93 190e
 
Join Date: Nov 2006
Location: Merrimack NH
Posts: 28
CEL Code 12 on my '93 190e 2.3

The code translates to "EGR Temp Sensor". Is this telling me I need to replace that rather expensive EGR Valve? Or could this simply be a vacuum leak or some other hopefully less expensive part??

-Steve

Reply With Quote
  #2  
Old 01-12-2009, 03:05 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
<--------------------------------------------------------------------------------

The code translates to "EGR Temp Sensor".>

Where did you get that code??
__________________
A Dalton
Reply With Quote
  #3  
Old 01-13-2009, 02:16 PM
08 C300 4matic, 93 190e
 
Join Date: Nov 2006
Location: Merrimack NH
Posts: 28
The Codes...from this Forum, actually...

Ah, from this forum I got the following for a '93 190e 2.3:

1 No fault found
2 Throttle position switch - wide open throttle fault
3 Engine coolant temperature sensor
4 Air flow sensor position indicator
5 Oxygen sensor
6 Not used
7 TD-signal (rpm)
8 Altitude correction capsule
9 Electronic hydraulic actuator (EHA)
10 Throttle position switch - closed throttle position fault (idle)
12 Exhaust gas recirculation temperature sensor

So when I counted the flashes I got 12! Of course I can't find a part called an "EGR Temp Sensor"...so I was interested in anyone elses solution to this. Could it be plugged vacuum hoses, the EGR Valve itself ($200+) or something else?

Steve
Reply With Quote
  #4  
Old 01-13-2009, 02:25 PM
slk230red's Avatar
WECO Installer
 
Join Date: Jul 2006
Location: Tampa, FL
Posts: 819
Quote:
Originally Posted by srhorn View Post
The code translates to "EGR Temp Sensor". Is this telling me I need to replace that rather expensive EGR Valve? Or could this simply be a vacuum leak or some other hopefully less expensive part??

-Steve

Steve,

What did you use to check codes on your car? Also, is it a California Model? Does yours have a check engine light?

EGR Temperature Sensor...Component B21 on my diagram is for California modes only.

Dave
__________________

1993 190E 2.3
2001 SLK230
1971 LS5 (454) Corvette Convertible

Last edited by slk230red; 01-13-2009 at 03:04 PM.
Reply With Quote
  #5  
Old 01-13-2009, 03:28 PM
08 C300 4matic, 93 190e
 
Join Date: Nov 2006
Location: Merrimack NH
Posts: 28
Not a California car...that i know of!

It's a late '93 190e 2.3 "Special Edition"...(It has the 300e leather interior and rear headrests, no rear badges, sunroof, 8 hole alloys, headlight washer/wiper). It was a one owner car from Massachusetts.

VIN is WDBDA28DXPG059400

It has the led and pushbutton near the battery...

Perhaps this model has the California bits???

-Steve
Reply With Quote
  #6  
Old 01-13-2009, 04:12 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
So, you got that code from the Built-in Led/Sw...
The question is did you get any codes from the other sockets?

You have Cal Emmissions .
__________________
A Dalton
Reply With Quote
  #7  
Old 01-13-2009, 04:24 PM
08 C300 4matic, 93 190e
 
Join Date: Nov 2006
Location: Merrimack NH
Posts: 28
Yes, apparently this car has California emmisions! Why, I have no idea. I tried the Russian vin decoder site and here's what I got (with some edits):

VIN WDBDA28DXPG059400
Model 190 E 2.3 AUSTRALIA
Chassis 2010281G059400
Engine 102985 12 115440
Transmission 722408 03 294066
Order 0 2 704 17357
Approx. year 1993
Dealer United States (USA) (704)
Interior leather mushroom (265)
Paint
269 avantgarde green (1992)
Options
221 left front seat, electrically adjustable (с 01.11.1978)

222 right front seat, electrically adjustable (с 01.11.1978)

240 outside temperature indicator (с 01.03.1982)

250 Alpine radio set (с 01.07.1989 по 31.10.1993)

260 elimination of model designation on rear lid (с 01.05.1968)
261
280 steering wheel (400 mm dia.) and gearshift lever in leather trim; on W202 390 mm dia. (с 01.05.1984)
285 ruffled pockets on left and right front backrests (с 01.07.1988)
340 additional 3rd stop lamp (с 01.10.1989)
412 electric sliding roof with tilting device (с 01.07.1983)
420 automatic transmission, floor shift (с 01.01.1963)
430 headrests in the rear (с 01.01.1977)
444 tempomat (cruise control) and airbag (с 01.02.1980 по 31.10.1993)
467 central locking system and instruments with english lettering (с 01.04.1970 по 31.10.1993)
494 California version
California version (с 01.05.1973 по 31.12.1995)
524 paintcoat preservation (с 01.01.1964)
543 sun visor with vanity mirror, illuminated, left and right (с 01.11.1978)
551 anti-theft warning system (с 01.11.1978 по 31.03.1998)
570 front folding armrest w202 - housing at front with armrest
586 Behr air conditioner, and electric window lifters (front and rear doors) (с 01.04.1970)
593 green heat-insulating glass all round, heated rear window, single pane safety glass - tinted strip (с 01.01.1972)
600 headlamp wiper/washer (с 01.08.1971)
639 elimination of first-aid box and warning triangle (с 01.08.1977)
652 8-hole light alloy rims (с 01.01.1990)
664 10 liters of fuel and mode of packing VE III (с 01.01.1979 по 30.06.1993)
803 Change of year of model, last figure shows new model year
814 active bass loudspeaker system (с 01.10.1989)
876 rear door contaCTS and lamp above rear window (с 01.07.1964 по 31.10.1993)

916

958 special model (limited version) (с 01.10.1993 по 31.12.1995)
special model w201 - USA (с 01.07.1992 по 30.09.1993)

Go figure. So how the heck do I find the California version parts?

-Steve
__________________
'93 190e 2.3
'08 C300 4matic
'04 BMW X3 2.5
Reply With Quote
  #8  
Old 01-13-2009, 05:32 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Cal Em. has CE lamp...the car does not have to come from Cal to have Cal Em.

The question is which diagnostc connector do you have .. The 16 pin or the 8.
That is the box where you got the Push Button code from.
__________________
A Dalton
Reply With Quote
  #9  
Old 01-13-2009, 10:46 PM
08 C300 4matic, 93 190e
 
Join Date: Nov 2006
Location: Merrimack NH
Posts: 28
Unfortunately my son just drove it back to school (Burlington Vermont), so I'll have to do this from memory...or wait for his return in a couple weeks (with all his laundry!). Anyone have a picture of the 8 pin or 16 pin??

Thanks!

Steve
__________________
'93 190e 2.3
'08 C300 4matic
'04 BMW X3 2.5
Reply With Quote
  #10  
Old 01-13-2009, 11:46 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
http://www.geocities.com/MotorCity/Downs/1039/mercedes/cs1000_mb.pdf
__________________
A Dalton
Reply With Quote
  #11  
Old 01-21-2009, 09:57 AM
08 C300 4matic, 93 190e
 
Join Date: Nov 2006
Location: Merrimack NH
Posts: 28
It's the 8 pin...

Finally got around to checking the pictures...and then remebered I also had a picture of the engine compartment from when the head gasket blew! So it is the smaller 8 pin unit. So the question is are the codes different from the 8 pin? What would the 12 flashes translate to?

Thanks!

Steve
__________________
'93 190e 2.3
'08 C300 4matic
'04 BMW X3 2.5
Reply With Quote
  #12  
Old 01-21-2009, 02:05 PM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
A posssible broken/split vac line to the ECU .... needed for monitoring Absolute Manifold pressures
__________________
A Dalton
Reply With Quote
  #13  
Old 01-22-2009, 09:49 AM
08 C300 4matic, 93 190e
 
Join Date: Nov 2006
Location: Merrimack NH
Posts: 28
Danke...

Okay...he'll be back next weekend...so I'll go through and replace as many of the vacuum lines I can...I would assume they are all pretty dried out after 16 years!

-Steve
__________________
'93 190e 2.3
'08 C300 4matic
'04 BMW X3 2.5
Reply With Quote
  #14  
Old 01-22-2009, 10:38 AM
slk230red's Avatar
WECO Installer
 
Join Date: Jul 2006
Location: Tampa, FL
Posts: 819
Quote:
Originally Posted by Arthur Dalton View Post
A posssible broken/split vac line to the ECU .... needed for monitoring Absolute Manifold pressures
There's vacuum line going to the ECU? All I see is the wired connector.
__________________

1993 190E 2.3
2001 SLK230
1971 LS5 (454) Corvette Convertible
Reply With Quote
  #15  
Old 01-22-2009, 10:44 AM
Registered User
 
Join Date: Aug 1999
Location: Florida / N.H.
Posts: 8,804
Sensor is wired to ECu ..but shold have a vac line going to it.

Little 1' square sensor with a 3 wire plug and a vac line.. Not sure of exact location on 201, but it is on the left /inner fender well on 124.


Post if you find it.........or if you have that CD, look for B5/2 sensor.

__________________
A Dalton

Last edited by Arthur Dalton; 01-22-2009 at 10:59 AM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page