Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-23-2011, 08:52 AM
Registered User
 
Join Date: Jun 2011
Posts: 1
89 300se stops at low speed

Runs rough at low speed- stops at random-difficult to restart

Reply With Quote
  #2  
Old 06-24-2011, 10:31 PM
mak mak is offline
mark
 
Join Date: Jul 2006
Location: Westfeld .
Posts: 687
Most likely it will be a failing fuel pump relay .Its misleading , seem like a ignition fault, but of course the engine restarts.
In my 300se i have found that by replacing the FPR and a fresh set of fuses sorted all the intermittant electrical problems.
I assume you have a new fuel filter and fuel accumulator .
__________________
mark
Reply With Quote
  #3  
Old 06-26-2011, 03:26 PM
Ron in SC's Avatar
Registered User
 
Join Date: Aug 2003
Location: Charleston, SC
Posts: 1,095
Quote:
Runs rough at low speed- stops at random-difficult to restart
I would change distributor cap and rotor. Get a Bosch. Also you can not test the cap and rotor under load, at least I can not.

This is unless you very recently did change cap and rotor.

Possibly crankshaft reference sensor, but I'd pass on that for now and do cap and rotor.

Edited
If you have a spare MAS relay you can swap them out and see if that's the problem.

Last edited by Ron in SC; 06-26-2011 at 03:38 PM.
Reply With Quote
  #4  
Old 06-26-2011, 09:39 PM
Registered User
 
Join Date: Jan 2008
Location: Melbourne Australia
Posts: 843
Shouldn't be a MAS relay on an '89.

Be careful with Bosch. There are some el cheapo erzatz "identical twin" Bosch leads and caps the come from the Middle Kingdom.
I would recommend OEM - Beru.
Reply With Quote
  #5  
Old 06-27-2011, 11:20 PM
mak mak is offline
mark
 
Join Date: Jul 2006
Location: Westfeld .
Posts: 687
Quote:
Originally Posted by Ivanerrol View Post
Shouldn't be a MAS relay on an '89.

Be careful with Bosch. There are some el cheapo erzatz "identical twin" Bosch leads and caps the come from the Middle Kingdom.
I would recommend OEM - Beru.

300SE:my 89 has the fuel pump relay ,MAS came following year on for 103.

__________________
mark
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page