Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-31-2014, 10:23 PM
Old School Mechanic
 
Join Date: Dec 2006
Location: Auburn California
Posts: 127
Bank 2 rich

2003 C320 the stft is about 2% rich on bank 2. Ltft adjusts well maintaining a -5 to -8%, but when I need a gutsy bust of power lftt 2 goes past -24% before the system can adjust.

How should I trouble shoot it? I'm thinking one or two of the injectors on 4,5,6 side are spraying too much. To head off the outliers: Side 1 is working finewith stft and ltft working both sides of 0 never building a bias + or -. Only the drivers side is running rich and only on some accelerations.

I'm thinking swap left and right front and middle injectors. If the problem remains, swap the back. If the problem remains, it is not the injectors. Then what?
Reply With Quote
  #2  
Old 11-01-2014, 06:59 AM
Hirnbeiss's Avatar
ich fahre, also bin ich
 
Join Date: Mar 2002
Location: South Florida
Posts: 1,600
Can you maybe swap O2 sensors first to rule that out?
__________________
Prost!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page