Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-09-2021, 07:59 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 1,239
94 e320 aux fan not working with ac

Was working properly last year .. this year I guess not. It does still switch on for cooling. What would be the first thing to check? Is there a separate relay?

__________________
1995 e320
1994 e320
2004 Jeep wj overland
2001 Ducati 748
2004 Honda shadow aero
Reply With Quote
  #2  
Old 04-09-2021, 08:16 PM
Diseasel300's Avatar
Registered User
 
Join Date: May 2016
Location: Texas Hill Country
Posts: 5,981
The fan runs on low speed based on refrigerant pressure. If you're low on charge, the head pressure may not be high enough to switch the fan on.
__________________
'91 560SEL - "Delta 88" 197K
'94 BMW 525i - "The Red Car" 181k
---Gone but not forgotten---
'86 300SDL - "The Diseasel" 190k (Totaled 1/31/19)
'91 350SD - "Jest-D" 176K (Sold 12/20/20)
Reply With Quote
  #3  
Old 04-09-2021, 08:33 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 1,239
Ac runs beautifully when moving. Iíll check that resistor
__________________
1995 e320
1994 e320
2004 Jeep wj overland
2001 Ducati 748
2004 Honda shadow aero
Reply With Quote
  #4  
Old 04-09-2021, 09:52 PM
Registered User
 
Join Date: Feb 2007
Location: los angeles
Posts: 737
take the 6 screws of fuse box cover to expose the 2 relays that control fans 1 is green with a fuse built in the other is blue with a fuse built in likey the fuse isw blown
Reply With Quote
  #5  
Old 04-30-2021, 06:47 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 1,239
Anyone have go to place to get that resistor?
__________________
1995 e320
1994 e320
2004 Jeep wj overland
2001 Ducati 748
2004 Honda shadow aero
Reply With Quote
  #6  
Old 04-30-2021, 07:28 PM
engatwork's Avatar
busy
 
Join Date: May 2000
Location: Soperton, Ga. USA
Posts: 12,945
Have you put 12 volts straight to the fans yet?
__________________
Jim
Reply With Quote
  #7  
Old 05-01-2021, 03:18 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 1,239
Quote:
Originally Posted by engatwork View Post
Have you put 12 volts straight to the fans yet?
The fans work. The ac isnít switching them on
__________________
1995 e320
1994 e320
2004 Jeep wj overland
2001 Ducati 748
2004 Honda shadow aero
Reply With Quote
  #8  
Old 05-01-2021, 03:50 PM
Diseasel300's Avatar
Registered User
 
Join Date: May 2016
Location: Texas Hill Country
Posts: 5,981
Quote:
Originally Posted by speednjay View Post
The fans work. The ac isnít switching them on
How long is this thread going to continue before you check the head pressure? Fans won't switch on until ~220PSI or so. If you're low on charge or the ambient temp is low, the fans won't kick on.
__________________
'91 560SEL - "Delta 88" 197K
'94 BMW 525i - "The Red Car" 181k
---Gone but not forgotten---
'86 300SDL - "The Diseasel" 190k (Totaled 1/31/19)
'91 350SD - "Jest-D" 176K (Sold 12/20/20)
Reply With Quote
  #9  
Old 05-01-2021, 10:24 PM
Registered User
 
Join Date: May 2010
Location: BAKERSFIELD, CA
Posts: 1,239
So I got it running. Nosing around checking things and found the ďdĒ fuse was melted. Replaced cleaned up things. Checked the relay fuses. Not sure if that was it because the fans do work when the engine got hot.
__________________
1995 e320
1994 e320
2004 Jeep wj overland
2001 Ducati 748
2004 Honda shadow aero
Reply With Quote
  #10  
Old 05-02-2021, 06:29 AM
rrgrassi's Avatar
mmmmmm Diesel...
 
Join Date: Jun 2006
Location: Royse City Tx
Posts: 5,055
I thought the Aux fans were AC refrigerant temperature related. They are not coming on on my 91 w.124 300D either. I am trying to find the wiring connections to do the direct 12 test. The 91 still called for R12.

__________________
RRGrassi


70's SPM #5608 Fairmont A-4 MOW car

06 VW Jetta TDI 290K miles

91 W124 300D Turbo replaced, Pressure W/G actuator installed. 188K

90 Dodge D250 5.9 Cummins/5 speed. 400K
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page