Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-02-2004, 11:38 AM
Registered User
 
Join Date: Mar 2004
Posts: 1
Electrical Problems

I just purchased a 1977 300D. The car has some sort of electrical problem whch I can not figure out. The fuses are all fine and I used a volt meter to verify voltage on both sides of the fuses. The following are dead: front parking lights, front turn signals, fog lights, dash lights, radio, heat works only on defrost . Any ideas? Is each one of these an issue to eal with or could thet all be related?

Jeff

Reply With Quote
  #2  
Old 03-02-2004, 06:31 PM
Ali Al-Chalabi's Avatar
Senior Member
 
Join Date: Nov 2000
Location: Knoxville, TN
Posts: 1,837
I would also make sure that the fuses are making good contact in the box. Sometimes the contacts can corrode a little and although the fuse appears to be in good condition, it does not have a good contact in the box.

__________________
Ali Al-Chalabi

2001 CLK55
1999 Dodge Ram 2500 Cummins Diesel
2002 Harley-Davidson Fatboy
Merlin Extralight w/ Campy Record
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page