Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-22-1999, 08:50 AM
crusader
Guest
 
Posts: n/a
I am attempting to replace the oem radio in my 300sd with a blauplunkt cd player. I am running into two problems.

First, the power plug shell to the radio opened up and the wires popped out. The slots where the wires are held in the case are labeled with a 1 2,3, and 4. Does anyone know which wires belong in which plug slot?

Second, I cannot seem to get enough 12V power to keep the radio's lcd displays lit let alone power the cd. When I plug it in, the lcd disply is bold but over the next 20 seconds it will fade away. I can take the cd player and put it in another car and it works fine. Any thoughts?

Lastly, what effect on the car's alarm system does having a non oem radio installed in the car?

Thanks in advance.
Reply With Quote
  #2  
Old 01-04-2000, 12:01 PM
Robert W. Roe's Avatar
Registered User
 
Join Date: May 1999
Location: Lehigh Valley PA
Posts: 1,330
This is just a wild guess, but perhaps you have the power input connected to the dimmed lighting circuit rather than +12VDC?
Reply With Quote
  #3  
Old 01-04-2000, 04:45 PM
Michael's Avatar
Veteran
 
Join Date: Jul 1999
Location: CT, USA
Posts: 2,699
Changing the radio will have no effect on the alarm system.

As to the power lead, did you test the voltage? Did you test ALL of the wires?? When I replaced my radio, I used the power leads in the car, so I doubt you should have any probs. Let us know where you're at, and good luck!

P.S. As to the wire leads, I'd call a Blau dealer

------------------
Best regards, Michael
'92 500E
'88 300TE
Reply With Quote
  #4  
Old 01-04-2000, 10:06 PM
Robert W. Roe's Avatar
Registered User
 
Join Date: May 1999
Location: Lehigh Valley PA
Posts: 1,330
Are there only four wires? If so, there could be as many as: switched positive hot +12VDC, unswitched positive hot +12VDC, dimmed 0-12VDC, and the antenna output. There could be only four if Becker got its ground (negative) from the chassis. I take it the speakers are wired onto a separate plug?


------------------
Robert W. Roe
1984 300SD 167K mi
Reply With Quote
  #5  
Old 01-08-2000, 09:46 AM
crusader
Guest
 
Posts: n/a
I finally took the car to an audio dealer for resolution. He said that I had my hot & ?? wires crossed so that accounted for the strange power behaviour. However, he was not sure wich was the antenna wire and if the antenna is positive or negative voltage. If anyone can give me this info, I would be most appreciative.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
replacing radio DCM Car Audio and Multimedia 5 05-26-2002 03:56 PM
Replacing radio 77 240d DCM Car Audio and Multimedia 1 05-10-2002 02:00 AM
Power Steering Problem - Need Advice arnelrac Tech Help 3 02-10-2002 12:05 AM
Replacing radio (Becker Mexico) W116 300SD omy1ron Car Audio and Multimedia 2 10-09-2001 01:56 AM
Having trouble replacing power steering belt WmHarlow Tech Help 8 07-06-2000 01:52 AM



All times are GMT -4. The time now is 02:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page