Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-11-2013, 06:59 PM
Austin85's Avatar
Smells like Diesel..
 
Join Date: Jun 2005
Location: Boca Raton, Fl
Posts: 2,723
HELP - Cassette adapter keeps popping out. Ejecting.

Have a working Becker Europa AM/FM Cassette in my 240D and considering keeping it in for oem look, but the I-pod cassette adaptor won't stay inside the unit.

I have tried with a new Monster adaptor and my son's diff brand too and both eject after 1-2 seconds. Is there ANY way to remedy this so it won't eject??

If not the stations here in s. FLorida are pathetic and I'll have to go aftermarket.

Thanks! Austin


...
__________________
'87 924S
'81 280SEL

Sold ->

81 300SD -
93 300E w/ 3.2
85 300D-
79 300SD
82 300CD
83 300CD - CA
87 190E 5 spd
87 Porsche 924S

"..I'll take a simple "C" to "G" and feel brand new about it..."

Reply With Quote
  #2  
Old 05-12-2013, 10:38 AM
Austin85's Avatar
Smells like Diesel..
 
Join Date: Jun 2005
Location: Boca Raton, Fl
Posts: 2,723
dont all chime in at once
__________________
'87 924S
'81 280SEL

Sold ->

81 300SD -
93 300E w/ 3.2
85 300D-
79 300SD
82 300CD
83 300CD - CA
87 190E 5 spd
87 Porsche 924S

"..I'll take a simple "C" to "G" and feel brand new about it..."

Reply With Quote
  #3  
Old 05-12-2013, 11:01 AM
Dubyagee's Avatar
All fields are required
 
Join Date: Jul 2006
Location: SE
Posts: 4,881
I asked the same question. No help. Becker said the tape mechanism needed servicing/lube. I haven't sent it in yet.
Reply With Quote
  #4  
Old 05-12-2013, 11:26 AM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,212
Try putting in a tape. Before it ejects push the fast forward and let it run all the way through the tape. Do it several times. Sometimes they just get a little "rusty" and do not want to work. I do this to get my Becker to play my tapes and sometimes it works, and sometimes not.
Reply With Quote
  #5  
Old 05-12-2013, 02:43 PM
Cleeve's Avatar
Registered User
 
Join Date: Apr 2002
Location: Lakeside, Ca.
Posts: 350
Cass Problem

Hi Austin85,

Some of the cass adaptors do not make both reels on the tape move at the same time. Make sure that the adaptor you have allows the two reels on the adaptor to move together. If that is not the problem then you could have a problem with the tape section of the radio. The reels could be slowing up with the use of the adaptor. A question I would have is - does the radio play any tapes?? If so, the the adaptor is definitely slowing the internal reels of the radio enough to trip the sensors inside the radio. If it won't play any tapes then servicing the tape section of the radio is the only way to correct the problem unless you have it modified for Aux input by someone like myself. Thank you for using the forum.

Cleeve Morrison
Morrison Palmer Engineering
MPE_Web_Site Page 1 of 6
Reply With Quote
  #6  
Old 05-13-2013, 12:26 AM
Austin85's Avatar
Smells like Diesel..
 
Join Date: Jun 2005
Location: Boca Raton, Fl
Posts: 2,723
Quote:
Originally Posted by tyl604 View Post
Try putting in a tape. Before it ejects push the fast forward and let it run all the way through the tape. Do it several times. Sometimes they just get a little "rusty" and do not want to work. I do this to get my Becker to play my tapes and sometimes it works, and sometimes not.
Tapes play through w/o ejecting. The heads may be dirty or they drag a little slow but they don't eject. I guess I can try FF on tapes to see if it loosens up the rust.

AA
...............
__________________
'87 924S
'81 280SEL

Sold ->

81 300SD -
93 300E w/ 3.2
85 300D-
79 300SD
82 300CD
83 300CD - CA
87 190E 5 spd
87 Porsche 924S

"..I'll take a simple "C" to "G" and feel brand new about it..."

Reply With Quote
  #7  
Old 05-13-2013, 12:30 AM
Austin85's Avatar
Smells like Diesel..
 
Join Date: Jun 2005
Location: Boca Raton, Fl
Posts: 2,723
Quote:
Originally Posted by Cleeve View Post
Hi Austin85,

Some of the cass adaptors do not make both reels on the tape move at the same time. Make sure that the adaptor you have allows the two reels on the adaptor to move together. If that is not the problem then you could have a problem with the tape section of the radio. The reels could be slowing up with the use of the adaptor. A question I would have is - does the radio play any tapes?? If so, the the adaptor is definitely slowing the internal reels of the radio enough to trip the sensors inside the radio. If it won't play any tapes then servicing the tape section of the radio is the only way to correct the problem unless you have it modified for Aux input by someone like myself. Thank you for using the forum.
Cleve,

Checked and both reels on the Monster adaptor move together.
Tapes play through w/o ejecting. (The heads may be dirty or they drag a little slow but they don't eject. )
What did you mean by "...a problem with the tape section of the radio.."?

Or any other suggestions?.....Thanks,
Austin

..
__________________
'87 924S
'81 280SEL

Sold ->

81 300SD -
93 300E w/ 3.2
85 300D-
79 300SD
82 300CD
83 300CD - CA
87 190E 5 spd
87 Porsche 924S

"..I'll take a simple "C" to "G" and feel brand new about it..."

Reply With Quote
  #8  
Old 05-13-2013, 12:33 AM
Austin85's Avatar
Smells like Diesel..
 
Join Date: Jun 2005
Location: Boca Raton, Fl
Posts: 2,723
Quote:
Originally Posted by Dubyagee View Post
I asked the same question. No help. Becker said the tape mechanism needed servicing/lube. I haven't sent it in yet.
Hey DB,

Some suggestions above but if you are willing to spend $55 bucks I found this on Ebay "Becker Europa Grand Prix STEREO iPod MP3 Adapter Cable - Full Stereo" Link - Blaupunkt Becker Europa Grand Prix Stereo iPod MP3 Adapter Cable Full Stereo | eBay

Looks perfect ...I would like to see if I can get the adaptor working . If not then I will probably spring for one of these..... AA

..
__________________
'87 924S
'81 280SEL

Sold ->

81 300SD -
93 300E w/ 3.2
85 300D-
79 300SD
82 300CD
83 300CD - CA
87 190E 5 spd
87 Porsche 924S

"..I'll take a simple "C" to "G" and feel brand new about it..."

Reply With Quote
  #9  
Old 05-13-2013, 04:17 PM
Austin85's Avatar
Smells like Diesel..
 
Join Date: Jun 2005
Location: Boca Raton, Fl
Posts: 2,723
update: Cassette played 1st time I used it - 1 time and was dragging- now it does same thing - EJECTS itself.

...>?
__________________
'87 924S
'81 280SEL

Sold ->

81 300SD -
93 300E w/ 3.2
85 300D-
79 300SD
82 300CD
83 300CD - CA
87 190E 5 spd
87 Porsche 924S

"..I'll take a simple "C" to "G" and feel brand new about it..."

Reply With Quote
  #10  
Old 05-27-2013, 04:10 PM
tyl604's Avatar
Registered User
 
Join Date: Feb 2008
Location: Atlanta, GA
Posts: 3,212
Sounds like the band that runs the tape player has stretched. Good for one run then warms up and stretches a bit. Just old.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page