Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-06-2015, 12:04 AM
Registered User
 
Join Date: Jul 2011
Posts: 369
1996 Mercedes c280 antenna not working

I replaced the old factor radio with a used one because the old one's lcd display was blacked out.

The car has the original phone.

Before removing and replacing the radio I forgot to disconnect the battery.
After replacing the radio, radio worked fine but I had strange thinks happening with the antenna. First, the antenna would stay on even after the car was turned off. Somehow I got the antenna to go down.

Now when I start the car and turn on the radio, the antenna does not come up.

Where do I begin diagnosing the problem?

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page