Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Car Audio and Multimedia

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-12-2004, 02:41 PM
bhatt's Avatar
Registered User
 
Join Date: Apr 2000
Location: Oakville, Ontario, Canada
Posts: 421
Angry Radio scrambled...

Hello,

My mechanic was taking my '87 560SL dash apart to replace something and disconnected my radio. Problem is, the alarm was going off at the time (previous owner had disconnected the horn, so mechanic had no way of knowing!) As a result, the Becker radio scrambled itself and now shows "-- -- -- --" on the display.

I know at this point, the dealer has to remove the faceplate and plug some kind of "key" unit into the radio to reenable it.

Took it to an MB dealer and the service manager obviously didn't know what he was doing. He tried for a few minutes and came back with two techs to help him. I wasn't near the car but was watching through the window.

He gave me the key back and said he tried but couldn't enable the radio. Said the radio kept coming up with a garbled display after he did it (said he tried 4 times) and that I should send the radio out for repair (!?!?!?)

This radio worked right before the alarm set it off.. I'm going to try another dealer tonight.. is there anything special I should tell them and is it possible that this radio is now hosed? Can't figure out why it now needs repair when it worked fine 2 days ago!!

Thanks!
Neal

__________________
'83 300SD 335,000km (207k) mi SOLD
'87 560SL 163,000km (101k mi) SOLD
'86 300SDL 356,000km (220k mi) SOLD
'92 500SEL 250,000km (155k mi) SOLD
'90 300SL 140,000km (87k mi) SOLD
'01 S430 260,000km (161k mi) SOLD
'03 SL500 167,000km (104k mi) SOLD
'07 S550 4MATIC 235,000km (146k mi) SOLD
'07 GL320 CDI 4MATIC 348,000km (215k mi)
'13 GL350 BlueTec 4MATIC 170,000km (105k mi)
'14 SL550 72,000km (43k mi)
Reply With Quote
  #2  
Old 01-12-2004, 05:15 PM
Zeus's Avatar
Moderating, Eh?
 
Join Date: Feb 2000
Location: Canada
Posts: 1,774
Welcome to Beckerland.

That's one of the many reasons I replaced my Becker with an Alpine head unit. I would not bother repairing it, rather I'd replace it with a new head unit that suits your style and requirements. Good luck!
__________________
Chris
2007 E550 4Matic - 61,000 Km - Iridium Silver, black leather, Sport package, Premium 2 package
2007 GL450 4Matic - 62,000 Km - Obsidian Black Metallic, black leather, all options
1998 E430 - sold
1989 300E - 333,000 Km - sold
1977 280E - sold
1971 250 - retired


"And a frign hat. They gave me a hat at the annual benefits meeting. I said. how does this benefit me. I dont have anything from the company.. So they gave me a hat." - TheDon
Reply With Quote
  #3  
Old 01-13-2004, 02:50 PM
Cleeve's Avatar
Registered User
 
Join Date: Apr 2002
Location: Lakeside, Ca.
Posts: 350
Radio Problem

Hi bhatt,

The radio that should be in your car is a Becker BE-754. If that is correct then what has happened is the internal battery is bad in the radio. This common and is replaceable. When power is disconnected from the radio with a bad battery inside you will get '----' on the display. Once the battery is changed you will need the dealer to encode the radio with their tool that they were using. If that is done and the radio still won't work properly then it will have some type of internal problem and require service. The options you would have is to have it serviced or to replace it with an aftermarket radio. As for the cost it will probably be close to the same for either way. If you need further help from me let me know.

Cleeve Morrison
La Jolla Audio Repair

www.lajollaaudiorepair.com

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2023, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page