Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-19-2004, 09:31 PM
Coming back from burnout
 
Join Date: Jun 1999
Location: in the Pacific Northwest
Posts: 2,274
Why did I lose my interior lighting after hooking up stereo to ACC wire?

On my 85 300D I lost all my dsahboard and console lighting after connecting a radio and its ACC wire to the ACC wire in the radio harness. I know theres a rheostat on the back of the Cluster that controls this lighting. Does anyone know how I can restore my interior lighting now? I dont need some of the lights but I do depend on the speedo and gas guage and temp guage...

Reply With Quote
  #2  
Old 10-19-2004, 09:40 PM
rg2098's Avatar
Detailing Moderator
 
Join Date: Jun 2004
Location: Rochester Hills, MI
Posts: 2,415
The extra draw might have been just enough to finally make the rheostat break. Its sounds reasonable as thats the commom point in the dash lighting system. I fixed my lights by just soldering a small jumper wire onto the contacts on the back of the rheostat.
__________________
Adam Lumsden
(83) 300D
Vice-President of the MBCA International Stars Section
Reply With Quote
  #3  
Old 10-19-2004, 09:52 PM
Coming back from burnout
 
Join Date: Jun 1999
Location: in the Pacific Northwest
Posts: 2,274
Thanks!!!

So I dont have to buy a new rheostat, right?
Reply With Quote
  #4  
Old 10-19-2004, 10:10 PM
rg2098's Avatar
Detailing Moderator
 
Join Date: Jun 2004
Location: Rochester Hills, MI
Posts: 2,415
Not unless you absolutly need to dim them. I bought a new one for the 450 when it failed and the new one didn't work other then full on. The wire trick is virtuially free and much more durable then the actual rheostat.
__________________
Adam Lumsden
(83) 300D
Vice-President of the MBCA International Stars Section
Reply With Quote
  #5  
Old 10-21-2004, 11:59 PM
Coming back from burnout
 
Join Date: Jun 1999
Location: in the Pacific Northwest
Posts: 2,274
Got an idea?

I pulled my cluster on my 85 300D and I jumped the 2 rheostat connections to make panel lights brighter.
I also noticed that someone was there before and partially cracked e the round keyed electrical connector that runs the show. Also pin 15, the ground pin is missing a lot of brown plastic material around it.
I also noted that when putting in a 1 filament vice double filament (required) bulb into the turn signal/running lamp makes the dash turn indicators screwy...

Anyway my Fuel and Temp guage max out now and my seat belt light comes on periodically. I hate electrical troubleshooting, sometimes it defies analysis................

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page