Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-09-2005, 01:58 AM
Registered User
 
Join Date: Jul 2005
Posts: 3
Where is the Aux Fan Relay?. s350d, 94

Hi
I have my aux fan stuck running after shut the engine off. It will stay running over night and will keep on running until I pull the fuse out. The possibility is the relay that might be stuck closed. I already looked in and under the fuse box in the eng compartment, but can't find any relay.. the car info is 1994 W140 S350 diesel. Can somebody point me to the location of the relays? I have the feeling that it is different from W140 gas model.
Thanks in advance.
Reply With Quote
  #2  
Old 09-09-2005, 02:43 AM
Jay Jay is offline
Registered User
 
Join Date: Aug 2000
Location: Breinigsville,Pa.
Posts: 299
Just a guess. On my e300D both fan relays are behind the fuse box. When you remove the cover on the fuse box, there is another cover over the relay box. I had to remove 6 screws to remove the cover.
__________________
Thank you, Jay
83MB 300D 241K "The silver coffin"
10 Prius lll 1K
95 MB E300D 120K Mable
02 Saab 9-5 Areo 131K
Cannondale SR500
www.thecornerstonefamily.org/
Reply With Quote
  #3  
Old 09-09-2005, 12:18 PM
Registered User
 
Join Date: Jul 2005
Posts: 3
aux fan relay

Thank you, Jay. I already looked into the box last weekend, didn't see any relays at all but found the wire from the aux fan fuse (30 amp) leading through the firewall into the interior. I also looked inside underneath the dash still no relay. This weekend I will look into the 2 resisters in front of the 2 fans to see if they have anything to do with this incident. For now I just pull the fuse out when I park..! I will look more into the CD on different year, might come up with something..!
Thank you.
Reply With Quote
  #4  
Old 12-21-2008, 07:50 PM
Jadavis's Avatar
Registered User
 
Join Date: Oct 2005
Location: Tennessee
Posts: 995
Same problem, 3 years later...

1995 W140 S350

Same thing happened to me Thursday night. I came out from the hotel and it was completely dead. I checked the battery with a Fluke. It read .693 volts. The battery was completely dead.

When we hooked up for a jump start and noticed that the two aux fans came on with the keys in my pocket.

Any idea on where to look?

The choices are:
-Stuck relay
-Stuck temperature switch
-Possibly stuck AC Pressure switch

-Jim
__________________
1995 S350D, Green with black leather interior.
Bought January 2008 w/ 233,xxx miles.
I did 22,000 miles during the first year of ownership.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
M119 Viscous Fan mod & problems with aux. fan resistor-mod ke6dcj Performance Paddock 92 05-19-2010 10:36 AM
93 300D 2.5L Aux Fan dieselbeagel Diesel Discussion 0 07-21-2005 12:55 PM
450 SL aux fan relay biker77bill SL Forum 2 09-15-2003 10:31 AM
Klima relay solutions for '85 Stage_wizards Tech Help 0 08-08-2003 08:04 PM
Aux. Fan temp & mystery?? toknow Tech Help 4 08-01-2003 05:09 PM



All times are GMT -4. The time now is 12:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page