Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-31-2005, 04:51 AM
Registered User
 
Join Date: Oct 2005
Posts: 75
123 Tach Amp Cigerette Butt Fix Worked!

My tach on my 82 300td was not functioning at all. Well, i did some reading, got a butt off the ground. Unscrewed the trashcan looking device on the driver side inner fender, stuck it between the pins screwed it down tight and started it up. Fully functional tach now. Doesnt react slow or anything, works GREAT. thanks guys
Reply With Quote
  #2  
Old 10-31-2005, 09:26 AM
kmaysob's Avatar
Registered User
 
Join Date: Nov 2003
Location: mesa az
Posts: 1,673
it wont work for long though
__________________
have no worries.....President Obama swears "If you like your gun, you can keep it
Reply With Quote
  #3  
Old 10-31-2005, 09:33 AM
boneheaddoctor's Avatar
Senior Benz fanatic
 
Join Date: May 2004
Location: Hells half acre (Great Falls, Virginia)
Posts: 16,007
Quote:
Originally Posted by kmaysob
it wont work for long though
That was my experience too. Ended up buying a couple good used ones from a fellow member.
__________________
Proud owner of ....
1971 280SE W108
1979 300SD W116
1983 300D W123
1975 Ironhead Sportster chopper
1987 GMC 3/4 ton 4X4 Diesel
1989 Honda Civic (Heavily modified)
---------------------
Section 609 MVAC Certified
---------------------
"He who fights with monsters might take care lest he thereby become a monster. And if you gaze for long into an abyss, the abyss gazes also into you." - Friedrich Nietzsche
Reply With Quote
  #4  
Old 10-31-2005, 12:23 PM
Registered User
 
Join Date: Jun 2005
Posts: 50
yeah i tried it w cardboard and it only last a few weeks. what has been working great for me is a piece of pipe insulation. i cut a pice about an inch thick and put it under the cap inbetween the cap and the pin housing (the piece separates from the cap, be gentle when removing it). this way the insulation puts pressure on the pins when they go inside part mounted in the car and it keep contact w the pins. its worked fine for the past 3 months.
Reply With Quote
  #5  
Old 10-31-2005, 12:34 PM
Registered User
 
Join Date: Jun 2005
Location: NJ
Posts: 1,182
Piece of swimming pool noodle (left over from car seat repair) worked on my 123.
Who'd a thought swimming pool noodle to fix sagging seat, tach amp and to hold veggie tank in trunk from sliding around.
__________________
82 300D....went to MB heaven
90 350 SDL....excercising con rods
Reply With Quote
  #6  
Old 10-31-2005, 01:54 PM
Registered User
 
Join Date: Feb 2004
Location: Ontario, Canada
Posts: 481
Quote:
Originally Posted by propigskin
Unscrewed the trashcan looking device on the driver side inner fender, ........
Do I have this in my SDL or is this different on a 123?
My Tach reads low rpm but is stable and works all the time, so maybe this fix wouldn't help.
__________________
1991 M-B 560SEL Arctic White/Grey 99,000 Miles
1987 M-B 300SDL Ivory/Palomino 229,000 Miles (sold but never forgotten)
2006 Volvo XC70 Blue/Beige
1999 Porsche Boxster Arena Red/Savanna Beige
1972 Porsche 911 Viper Green/Black
Reply With Quote
  #7  
Old 10-31-2005, 04:35 PM
Registered User
 
Join Date: Jul 2004
Posts: 7,334
Quote:
Originally Posted by boneheaddoctor
That was my experience too. Ended up buying a couple good used ones from a fellow member.
And are they still working fine? I'll be back in South Florida and able then to pull parts in about a month tops. Tach amps are a usual find and not expensive. One I sent to BHD did not work so I sent him another one.
Reply With Quote
  #8  
Old 10-31-2005, 05:50 PM
dieseldiehard's Avatar
Dieseldiehard
 
Join Date: Oct 2002
Location: Bay Area No Calif.
Posts: 4,195
Quote:
Originally Posted by MTUpower
And are they still working fine? I'll be back in South Florida and able then to pull parts in about a month tops. Tach amps are a usual find and not expensive. One I sent to BHD did not work so I sent him another one.
If you have an extra from your trip let me have one (I'll pay the going rate) as the cigarette butt trick turned sour for me too!
DDH
__________________
'00 E320 (wifes car), '95 E320 Wagon my favorite road car. '99 E300D wolf in sheeps body, '87 300D Sportline suspension, '79 300TD w/ 617.952 engine at 367,750 and counting!
Reply With Quote
  #9  
Old 10-31-2005, 07:06 PM
boneheaddoctor's Avatar
Senior Benz fanatic
 
Join Date: May 2004
Location: Hells half acre (Great Falls, Virginia)
Posts: 16,007
Quote:
Originally Posted by MTUpower
And are they still working fine? I'll be back in South Florida and able then to pull parts in about a month tops. Tach amps are a usual find and not expensive. One I sent to BHD did not work so I sent him another one.
Working Fine on both cars....only one I had problems with is the one you replaced.
__________________
Proud owner of ....
1971 280SE W108
1979 300SD W116
1983 300D W123
1975 Ironhead Sportster chopper
1987 GMC 3/4 ton 4X4 Diesel
1989 Honda Civic (Heavily modified)
---------------------
Section 609 MVAC Certified
---------------------
"He who fights with monsters might take care lest he thereby become a monster. And if you gaze for long into an abyss, the abyss gazes also into you." - Friedrich Nietzsche
Reply With Quote
  #10  
Old 10-31-2005, 07:21 PM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,079
Thumbs up

Quote:
Originally Posted by Dervman
Do I have this in my SDL or is this different on a 123?
My Tach reads low rpm but is stable and works all the time, so maybe this fix wouldn't help.


'85+ cars have that small computer in the passenger kickpanel area for the Tach/EGR.
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 245k
'87 300SDL 251k
'90 300SEL 326k

Six others from BMW, GM, and Ford.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
  #11  
Old 10-31-2005, 09:17 PM
Brandon314159
Guest
 
Posts: n/a
Wouldn't have worked on my 300SD. *looks at old amp sitting on the desk*. I took it out...gave it a sniff with my nose and said...its done. Smelled like fried circuit board.

Picked one up and pocketed it at the wrecking yard off a w116 300SD that caught on fire. MB Tex smells BAD when it burns
Reply With Quote
  #12  
Old 10-31-2005, 09:54 PM
Diesel on the brain
 
Join Date: Nov 2002
Location: Upstate Virginia
Posts: 566
We did that fix on our old 83 300D. It worked for several (6+) years until it was traded in.

-Tad
__________________
1995 G320
2003 C230 Kompressor Coupe
2005 ML500
2007 ML350
Reply With Quote
  #13  
Old 10-31-2005, 10:54 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by Hit Man X
'85+ cars have that small computer in the passenger kickpanel area for the Tach/EGR.
Tach hasn't worked on my '85 wagon since I got it. Haven't tried to troubleshoot it yet. I guess I need to search first. duh....
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #14  
Old 10-31-2005, 11:00 PM
Hit Man X's Avatar
I LOVE BRUNETTES
 
Join Date: Sep 2004
Location: FUNKYTOWN
Posts: 9,079
Thumbs up

Quote:
Originally Posted by JimmyL
Tach hasn't worked on my '85 wagon since I got it. Haven't tried to troubleshoot it yet. I guess I need to search first. duh....


Well if PnP would drop their $36 price on it, I'd pick it up for ya. It's still where I left it out there.
__________________
I'm not a doctor, but I'll have a look.

'85 300SD 245k
'87 300SDL 251k
'90 300SEL 326k

Six others from BMW, GM, and Ford.

Liberty will not descend to a people; a people must raise themselves to liberty.
[/IMG]
Reply With Quote
  #15  
Old 10-31-2005, 11:09 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by Hit Man X
Well if PnP would drop their $36 price on it, I'd pick it up for ya. It's still where I left it out there.
Do they ever have half price day? Is that the one in Haltom City?
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page