Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-08-2006, 01:36 PM
Registered User
 
Join Date: Dec 2005
Location: New Jersey
Posts: 100
injector?

I have 95 E300D, when I start it up it makes the normal valve tap for 2-3 seconds then the oil pressure goes up and the noise goes away. after about 20-30 seconds a noise that sounds like a valve tap starts. it only goes for a few minutes until the car is warm. could it be a injector? oil pressure is fine and its full of oil. any suggestions would be great

__________________
Trying to keep Jersey Fresh

1995 E300D 384,000,(Betty White) part time greaser, lots of new parts
2004 Ranger XLT
2000 Chocolate Lab-Bad Quarter Panel, lots of miles
Reply With Quote
  #2  
Old 08-08-2006, 01:47 PM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
With 300K, I'd have the injectors looked at anyways. At 100K I had 1 injector with bad spray pattern and the pop off pressure was too low. I found that out when I decided to take the injectors out and have them cleaned and checked. Total bill came to about $60 for the testing of 6 injectors, cleaning of the one and retesting of that one.
__________________
01 Ford Excursion Powerstroke
99 E300 Turbodiesel
91 Vette with 383 motor
05 Polaris Sportsman 800 EFI
06 Polaris Sportsman 500 EFI
03 SeaDoo GTX SC Red
03 SeaDoo GTX SC Yellow
04 Tailgator 21 ft Toy Hauler
11 Harley Davidson 883 SuperLow
Reply With Quote
  #3  
Old 08-08-2006, 01:57 PM
Registered User
 
Join Date: Jan 2003
Location: Reno/Sparks, NV
Posts: 3,063
Are you using any fuel additives? What you're describing is a fairly common phenomenon and it's caused by sudden fuel combustion. In this case with the engine cold the glow plugs are the only thing that keeps the fuel igniting as soon as it's injected, thereby reducing knocking. That's why you start hearing the knock about 30 seconds after startup when the glow plugs turn off. It could be weak injectors, but it could also be just carbon buildup. That's why I suggest a good fuel additive, preferably one with a cetane boost.
__________________
2004 VW Jetta TDI (manual)

Past MB's: '96 E300D, '83 240D, '82 300D, '87 300D, '87 420SEL
Reply With Quote
  #4  
Old 08-09-2006, 08:35 AM
Registered User
 
Join Date: Dec 2005
Location: New Jersey
Posts: 100
thanks, the engine has about 165,000 miles but the injectors came out of my old engine. One of my glowplugs just burned out so that might be the problem.
__________________
Trying to keep Jersey Fresh

1995 E300D 384,000,(Betty White) part time greaser, lots of new parts
2004 Ranger XLT
2000 Chocolate Lab-Bad Quarter Panel, lots of miles
Reply With Quote
  #5  
Old 08-09-2006, 10:46 AM
aklim's Avatar
Registered User
 
Join Date: Apr 2000
Location: Location: Greenfield WI, USA
Posts: 8,514
Quote:
Originally Posted by longshore1 View Post
thanks, the engine has about 165,000 miles but the injectors came out of my old engine. One of my glowplugs just burned out so that might be the problem.
Just because they came out of the old engine doesn't mean they are good. I'd have them checked anywyas. Cost you some time, spacers and some rubber tubes with a terminator.
__________________
01 Ford Excursion Powerstroke
99 E300 Turbodiesel
91 Vette with 383 motor
05 Polaris Sportsman 800 EFI
06 Polaris Sportsman 500 EFI
03 SeaDoo GTX SC Red
03 SeaDoo GTX SC Yellow
04 Tailgator 21 ft Toy Hauler
11 Harley Davidson 883 SuperLow
Reply With Quote
  #6  
Old 08-09-2006, 02:14 PM
Registered User
 
Join Date: Jan 2003
Location: Reno/Sparks, NV
Posts: 3,063
Quote:
Originally Posted by longshore1 View Post
thanks, the engine has about 165,000 miles but the injectors came out of my old engine. One of my glowplugs just burned out so that might be the problem.
If one of your glow plugs burned out, that would definitely do it. I was assuming in my last post that you had already checked your glow plugs. Take care of your glow plugs first.

__________________
2004 VW Jetta TDI (manual)

Past MB's: '96 E300D, '83 240D, '82 300D, '87 300D, '87 420SEL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page