Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-25-2007, 04:13 PM
Registered User
 
Join Date: Jul 2006
Location: Raleigh, NC
Posts: 13
AC Functioning Poorly (240D)

After finishing up more important repairs, I'm now working on the AC. That said, I am in need of advice on how to proceed, as I've never really worked on this part of the car before.

Here is the problem:
- Currently, the vent temperatures are perhaps 10 degrees F lower than outside. Only when driving constantly, like on the highway, will the temperatures will get that "low".

Here's what I know:
- The system is charged (R12), and has no leaks.
- The compressor turns on.
- The electric fan on the condenser does not turn on. The fan itself works, and spins when connected directly to power. However, it will not turn on during use, even on 95F+ days.


How do I go about troubleshooting the electric fan, and the system overall?


Thanks

__________________
1983 240D
Reply With Quote
  #2  
Old 06-25-2007, 11:47 PM
jbaj007's Avatar
Registered User
 
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
Aux fan only turns on when high side refrigerant pressure gets high. Jumper the wires to the pigtails of the pressure switch on receiver/dryer .

Beg, borrow or steal gauge set (Autozone loan program?) and take hi and lo pressures at 1500-2000 RPM. report pressures, ambient temp and vent temp. Do with door open, system on high.

Heavily mist the condensor with water spray; observe vent temps and pressures. report back.

I'm not the brightest, but I've done a bunch of these old A/C systems with some success.

History of system and why you're sure of leak status and charge status?
__________________
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
  #3  
Old 06-26-2007, 10:29 AM
Registered User
 
Join Date: Jul 2006
Location: Raleigh, NC
Posts: 13
Thanks for the response.

History of the system - I've been driving this car for ~7 years. Didn't need a recharge until I replaced the compressor about 3 years ago (of course). A/C performance had been decent until sometime in the past year. I'm assuming it is charged, since it only took about 1/4-1/3 can of R12 about a month ago.


I'll see if I can swipe some gauges from a friend and take the pressures.

__________________
1983 240D
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:38 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page