Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-30-2008, 10:06 PM
lowriderdog37's Avatar
Unregistered User
 
Join Date: Mar 2007
Location: Viera, FL
Posts: 665
'85 300CD oil question

Hey all, to start, I want to start by telling you that I have always put Rotella t (blue bottle) 5W-30, and I just changed it a few weeks ago.

I was driving earlier today, and noticed the oil pressure was just above 2 bar. When I went to idle, it went to about 1 1/3 bar like usual. I stopped and checked the oil level, it was right in the middle of the marks. The thing that got me thinking is that it ran off the dipstick like melted bitter on a hot knife.

I live in Louisiana, and it's hot here, but not as hot as it has been lately (it was only about 90 today). I also noticed that the oil gauge had a little click in it when it was dropping. I just took the gauge set out to fix the key spindle, so that could* have something to do with it.

I am going to go out and mess with it right now. What does this all sound like?
__________________
My Primary Driver - '85 300CD - 4-speed conversion, 2.47 rear, lowered, euro headlights, rebuilding (not restoring so much)

Wife's - '08 Saab Sportcombi Aero

Riding a '03 Yamaha Warrior
Reply With Quote
  #2  
Old 06-30-2008, 11:40 PM
lowriderdog37's Avatar
Unregistered User
 
Join Date: Mar 2007
Location: Viera, FL
Posts: 665
A little update...I just got back in from messing around with this issue. I took the gauge set apart, checked it out, good operation...put it back together, checked for leaks around the oil lines, nothing. Checked the oil level again, it was fine...stuck to the dipstick like...well, oil from a diesel.

Started the car, and what do you know, pressure is reading just fine. I went for a drive, the pressure was just fine. I didn't hear anything weird, so I punched it a few times, everything was fine.

Once I got home, I checked the dipstick again, the level was fine, but the oil was streaking off again like I explained before. Is this normal?

I am taking a trip on Thursday, and I am pretty sure the car is just f^*king with me. I had problems with the key turning over the weekend, I took that apart, put it back together, and it's working fine now too.
__________________
My Primary Driver - '85 300CD - 4-speed conversion, 2.47 rear, lowered, euro headlights, rebuilding (not restoring so much)

Wife's - '08 Saab Sportcombi Aero

Riding a '03 Yamaha Warrior
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page