Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-07-2008, 06:03 PM
Registered User
 
Join Date: Jul 2003
Location: Bellevue WA
Posts: 174
W124 Rear Defroster defogger Inop

The last several mornings I have noticed that I do not see the lines where the heating elements are located in the rear window. The dash light does come on when I turn it on-but apparently no heating. Are there any fuses that could cause this-or am I dealing with a need for a window glass replacement?
__________________
87 300D 265Kmi
Factory rebuilt crate 603.96x engine at 200K
Reply With Quote
  #2  
Old 11-07-2008, 06:25 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 20,391
How much time do you give it? Mine's really slooow and it's not that cold in San Jose.

Fuse 1 is for the switch, fuse 10 is for the heating elements. There is a relay in the aft section of the fuse box that directs power to the heating elements on a 15 minute timer. It's the long relay in the middle row.

Sixto
87 300D
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page