Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-24-2009, 07:57 PM
Registered User
 
Join Date: Apr 2005
Posts: 120
1979 300sd Trans. No pressure at radiator.

Through the process of elemination and the help of this forum I have learned that when the line on the radiator is removed, car running or not and in or out of gear I get a dribble at best out of the line.

Its looking and sounding like a front pump issue...if anyone else has any ideas or some advice on this latest revelation I woud certainly appreciate it.

Thanks,

Dave
__________________
Dave
Las Vegas, Nevada
Reply With Quote
  #2  
Old 01-25-2009, 12:23 AM
Registered User
 
Join Date: Apr 2005
Posts: 120
Ive searched and searched...

If I have no pressure at the lines...is it black and white that the pump in the trans has gone out or sheared off the splines in the TC?

Is there any other potential causes for my transmission suddenly and quietly deciding to take the week off???

Thanks

Dave (again)
__________________
Dave
Las Vegas, Nevada
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page