Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-03-2009, 10:58 AM
Registered User
 
Join Date: Aug 2005
Posts: 81
1999 E300 TD Electrical Woes

I have a 1999 E300 TD. Intermittently, my front power windows, power seats and power mirrors all stop working - all at the same time.

I spoke with the owner of another E300 TD and he told me he had the same problem and solved it by disconnecting and reconnecting the battery. I did the same and the windows, seats and mirrors all worked again. But every 5 to 6 days, it happens again and I have to disconnect the battery to get the windows, mirrors and seats to work. It's very frustrating. Any idea what might be causing this?
__________________
1999 E300 Turbo - 112K miles
1987 300D Turbo - 89K miles
1984 190D 5spd - 152K miles
1969 220D Auto - 170K miles
Reply With Quote
  #2  
Old 02-03-2009, 11:03 AM
Moderator
 
Join Date: Jul 2001
Location: Old Lyme, Connecticut
Posts: 3,596
No known reasons, but it seems there must be a ground or other problem in the connections to the controls. You don't blow fuses and the equipment will work (do you have to synchronize them after every battery disconnect?), so the problem would appear to lie in the control system connection - either power in or grounding.

Good luck, and keep us posted if you find out what this is all about. Jim
__________________
Own:
1986 Euro 190E 2.3-16 (291,000 miles),
1998 E300D TurboDiesel, 231,000 miles -purchased with 45,000,
1988 300E 5-speed 252,000 miles,
1983 240D 4-speed, purchased w/136,000, now with 222,000 miles.
2009 ML320CDI Bluetec, 89,000 miles

Owned:
1971 220D (250,000 miles plus, sold to father-in-law),
1975 240D (245,000 miles - died of body rot),
1991 350SD (176,560 miles, weakest Benz I have owned),
1999 C230 Sport (45,400 miles),
1982 240D (321,000 miles, put to sleep)
Reply With Quote
  #3  
Old 02-03-2009, 04:06 PM
Registered User
 
Join Date: Jan 2003
Location: Reno/Sparks, NV
Posts: 3,063
I'd examine the fuse for these items. It may have a slight crack leading to an intermittent operation.
__________________
2004 VW Jetta TDI (manual)

Past MB's: '96 E300D, '83 240D, '82 300D, '87 300D, '87 420SEL
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page