Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-08-2009, 02:07 PM
Aquaticedge's Avatar
Bump on a log
 
Join Date: Nov 2009
Location: See Biography
Posts: 3,148
450.00 Dollars later and my car is Awesome again

I wanted to give an update and conclusion to many of my topics all in one. I had the repair shop replace my motor mounts, (completely shot) my Transmission mount (even worse then the motor mounts) and a few odds n ends done Ie Fuel filters etc, I did find out I need tie rods, and ball joints so thats next months adventure. but I got power back, and this car idles so much better. Thank you all for tellin me what was wrong and helping me though it. the only thing left for me to do is injectors etc... Thanks!

__________________
hum.....
1987 300TD 311,000M Stolen. Presumed destroyed
Reply With Quote
  #2  
Old 12-08-2009, 03:12 PM
One step at a time
 
Join Date: Sep 2009
Location: Burleson, TX
Posts: 426
What led you to the motor mounts? Was it rocking to and fro?

Or did you just do a visual inspection?

I think I saw somewhere here that a quick check for the motor mounts is to jack up the engine a bit and see if the car stops shaking...?
__________________
----Adam

1985 300SD 322,000
Reply With Quote
  #3  
Old 12-08-2009, 03:42 PM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
Whoo Hoo!!
__________________
83 SD

84 CD
Reply With Quote
  #4  
Old 12-08-2009, 07:35 PM
Aquaticedge's Avatar
Bump on a log
 
Join Date: Nov 2009
Location: See Biography
Posts: 3,148
the mounts were fairly compressed, the whole car would shake at idle pretty bad. the Transmission mount was a surprise to me. It was very badly degraded and the new one raised it back in to position about 3 inches from where it was, it was quite shocking to see how bad it was. I also found out my Tie rod boots are all cracked and falling apart. as well as the original Factory ball joints in the car.. so that explains the front end creaking noise

__________________
hum.....
1987 300TD 311,000M Stolen. Presumed destroyed
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page