Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-24-2009, 04:46 PM
Registered User
 
Join Date: Jun 2008
Location: Orlando, FL
Posts: 1,269
Bought Norm an early Christmas present

Just installed it, took maybe 15 minutes tops. It's a GREAT head unit, and I finally have an AUX port for my iPod. It's not too "neon ricer awesome", and it actually has preset buttons which is nice. I think it suits the car well.

The one that Tyler installed is off to Colorado where it will sit in my dad's Eurovan.







Reply With Quote
  #2  
Old 12-24-2009, 05:36 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
Nice, here is my Christmas present for the W115.

I wanted a German radio, LOL.

http://www.midwestelectronics.com/blaupunkt-san-francisco-300-p-682.html

I'll post pics of it installed later

BTW, I have a decent Climate control face, looks like the paint is coming off yours that I could let go for cheap if you want it.
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #3  
Old 12-24-2009, 05:51 PM
Registered User
 
Join Date: Jun 2008
Location: Orlando, FL
Posts: 1,269
Got pics?

I'm replacing the CCU with one that Jimmy sent me (pretty sure my temp dial is dead), but it's all white. I'd like to keep the blue.

That'll be my next undertaking, I have the compressor, dryer, and expansion valve here. Just need time to do it all.
Reply With Quote
  #4  
Old 12-24-2009, 05:56 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
Let me go take a picture, its blue too.
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #5  
Old 12-24-2009, 06:19 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #6  
Old 12-24-2009, 06:36 PM
Registered User
 
Join Date: Jun 2008
Location: Orlando, FL
Posts: 1,269
PM sent.

And yours is nice! Should look good in the 115. I like the simplicity of it.

It's amazing how many terrible looking "flashy" head units there are out there.
Reply With Quote
  #7  
Old 12-24-2009, 06:37 PM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
Yeah that Blaupunkt has straight lines that will go well with the W115 interior.

I didn't want any "ricey" radio, LOL.
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #8  
Old 12-24-2009, 11:06 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
I think that looks nice Colin!
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #9  
Old 12-24-2009, 11:17 PM
TheDon's Avatar
Open Discussion Moderator
 
Join Date: Oct 2005
Location: Windermere,FL
Posts: 13,205
awesome Colin.

I'm just going to go with a stock unit from Tyler for the cabrio. I think I want to keep it original if I do in fact keep that car
__________________

|1983 300D| OM617 239k Miles|Red|"Passion"|
|1982 300D Euro|OM617 NA| Thistle Green|"Granny Smith|
Reply With Quote
  #10  
Old 12-24-2009, 11:35 PM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by TheDon View Post
awesome Colin.

I'm just going to go with a stock unit from Tyler for the cabrio. I think I want to keep it original if I do in fact keep that car
Come on, you're not gonna keep that car.
Besides, a convertible W124 is a girls car anyway.....{I'm just sayin'}
__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #11  
Old 12-25-2009, 12:03 AM
okyoureabeast's Avatar
Rogue T Tolerant
 
Join Date: Jul 2009
Location: North America
Posts: 1,294
That climate control unit is just crazy. It looks so different from mine.
__________________
Quote:
Originally Posted by Yak View Post
Going back to the original post: "Can you get the vac to blow instead?" No. Vacuums are low pressure so they by nature "suck" and nature abhors them.
1984 380SL
Reply With Quote
  #12  
Old 12-25-2009, 12:19 AM
TylerH860's Avatar
KHAAAAAAN-gress
 
Join Date: Aug 2007
Location: Wichita, Ks
Posts: 5,187
I didn't install that abortion of a faceplate. Norm came with it. Not only was is a funky silver that clashed with the car, it beeped with every thing you did and was way too bright. I hated it. Ingrid is cursed with a similar stereo. At least its black, but has the same annoying beep and is obnoxiously bright.
__________________
1985 500SL Euro w/ AMG bits 130k
1984 300SD Turbodiesel 192k
1980 240D Stick China 188k
2001 CLK55 AMG 101k
2007 S600 Biturbo 149k Overheated Project, IT'S ALIVE!!!
Reply With Quote
  #13  
Old 12-25-2009, 12:22 AM
TylerH860's Avatar
KHAAAAAAN-gress
 
Join Date: Aug 2007
Location: Wichita, Ks
Posts: 5,187
Quote:
Originally Posted by okyoureabeast View Post
That climate control unit is just crazy. It looks so different from mine.
Yes, it looks like it belongs in a Nuclear missile station in the 1970s. Let's hope they had better technology than that Chrysler designed pile of crap.

Cue Jimmy and some evil servo pictures.
__________________
1985 500SL Euro w/ AMG bits 130k
1984 300SD Turbodiesel 192k
1980 240D Stick China 188k
2001 CLK55 AMG 101k
2007 S600 Biturbo 149k Overheated Project, IT'S ALIVE!!!
Reply With Quote
  #14  
Old 12-25-2009, 12:54 AM
JimmyL's Avatar
Rogue T Intolerant!!!
 
Join Date: May 2004
Location: Sunnyvale, Texas (DFW)
Posts: 9,673
Quote:
Originally Posted by TylerH860 View Post

Cue Jimmy and some evil servo pictures.
Was I summoned??



__________________
Jimmy L.
'05 Acura TL 6MT
2001 ML430 My Spare

Gone:
'95 E300 188K "Batmobile" Texas Unfriendly Black
'85 300TD 235K "The Wagon" Texas Friendly White
'80 240D 154K "China" Scar engine installed
'81 300TD 240K "Smash"
'80 240D 230K "The Squash"
'81 240D 293K"Scar" Rear ended harder than Elton John
Reply With Quote
  #15  
Old 12-25-2009, 02:02 AM
Registered User
 
Join Date: Jun 2008
Location: Orlando, FL
Posts: 1,269
Quote:
Originally Posted by TylerH860 View Post
I didn't install that abortion of a faceplate. Norm came with it. Not only was is a funky silver that clashed with the car, it beeped with every thing you did and was way too bright. I hated it. Ingrid is cursed with a similar stereo. At least its black, but has the same annoying beep and is obnoxiously bright.
Thank god, I expected better taste from you! It was just down right annoying, it beeped ever time you changed the channel, pressed a button, whatever. And every time you got out of the car it beeped for like 10 seconds. At least it was installed somewhat properly. The Sony's are annoying.

Quote:
Originally Posted by TylerH860 View Post
Yes, it looks like it belongs in a Nuclear missile station in the 1970s. Let's hope they had better technology than that Chrysler designed pile of crap.

Cue Jimmy and some evil servo pictures.
And pretty much everyone who rides in the car says "what the hell is that thing?!" as soon as they get in.

Hopefully this fixes it, otherwise hello digital servo.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page