Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-11-2010, 05:26 PM
GemstoneGlass
 
Join Date: Dec 2005
Location: Northern,Ca
Posts: 730
b2 piston

hi my 300 dt tranny only goes in reverse. i gather its most likely the b2 piston. reverse is strong, it does barely budge in foreward gears but no more than a very light feeling surge when put into foreward gear which barely rocks the car. ive got to check it before buying a b2 i gather. anything else it could be? it is at 250K or so.
by the way its been awhile. thanks again

__________________

Chris
84 280sl
82 300d euro
Reply With Quote
  #2  
Old 01-11-2010, 05:41 PM
Registered User
 
Join Date: Jun 2007
Location: new braunfels, TX
Posts: 290
Drain the tranny and pour the fluid through a coffee filter. If there is more than just a small amount of non metallic solids present. You can have clutch wear to the point of failure. Any metal peices of size could indicate band failure. Not saying this has happened, but a good place to start.
__________________
Dave
1983 300D Daily Driver







Reply With Quote
  #3  
Old 01-11-2010, 05:58 PM
Registered User
 
Join Date: Sep 2004
Posts: 8,730
Quote:
Originally Posted by blindwolf View Post
If there is more than just a small amount of non metallic solids present.
What is the rest of the conditional statement?
Reply With Quote
  #4  
Old 01-11-2010, 06:08 PM
Registered User
 
Join Date: Jun 2007
Location: new braunfels, TX
Posts: 290
You can have severe clutch wear.
__________________
Dave
1983 300D Daily Driver







Reply With Quote
  #5  
Old 01-11-2010, 10:14 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 30,015
Don't know if this will help or not as your problem sounds more severe:

About 1 moth ago I lost my 1st Gear after the Trans would warm up. It would not even shift into 1st when I moved the Shift Lever to Low.

Everthing pointed to the B2 Piston which I hesitated to replace as I wanted to take a peak at it first befor buying a new one or hunting up a used one. (We were still using the Car by manually moving the Shift Lever to 2nd and then to Drive; no Hills in the areas we drive.)

In the Mean time I changed my Transmission Filter. Now when I put it in Low with the Shift Lever low gear works.
It also appears to be working in Drive not but I have not had time to get the trans really hot to see if that will cause the problem again.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #6  
Old 01-12-2010, 08:49 AM
layback40's Avatar
Not Banned
 
Join Date: Nov 2009
Location: Victoria Australia - down under!!
Posts: 4,023
Blindwolf sounds to be on the right track.

Could you please give a little history to the problem.
Did it gradually get worse over many thousands of miles, or did it happen reasonably suddenly?
Did you loose use of 1 gear at a time?
Did it start to happen with flaring on changes?
What is the history of trans fluid changes?
Any other info about the car.
__________________
Grumpy Old Diesel Owners Club group

I no longer question authority, I annoy authority. More effect, less effort....

1967 230-6 auto parts car. rust bucket.
1980 300D now parts car 800k miles
1984 300D 500k miles
1987 250td 160k miles English import
2001 jeep turbo diesel 130k miles
1998 jeep tdi ~ followed me home. Needs a turbo.
1968 Ford F750 truck. 6-354 diesel conversion.
Other toys ~J.D.,Cat & GM ~ mainly earth moving
Reply With Quote
  #7  
Old 01-18-2010, 04:03 PM
GemstoneGlass
 
Join Date: Dec 2005
Location: Northern,Ca
Posts: 730
was flaring and rough shifts

it was shifting rough when cold and flaring I believe.
it just gave out suddenly at a stop light. it basically got about a mile from the house after sitting for 9 days
The fluid has been changed not filter, i admit the old fluid was quite sparkly.
I am thinking it needs a new tranny. its a bone yard engine and tranny. the engine is perfect, guess not with the tranny.
Should have done that 4speed switch as well. I guess that may be in order since i've still got all the parts. also unfortunately the vehicle is at my dads which is a 2.5 hour drive from me. so i cant just check things easily.
Oh sorry for the post and run earlier. I dont have internet at home anymore. just at the shop where its cold. also time is limited.
thanks again

__________________

Chris
84 280sl
82 300d euro
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page