Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-24-2010, 09:16 AM
Certified Moron
 
Join Date: Apr 2010
Posts: 44
Electrical Troubleshooting: Windows 300SD

I recently replaced the window relay in my 300SD, now driver's side window works, and have discovered the rear driver's side needs a regulator. Neither window works on the passengers side of the car. I was driving the car last night and noticed that the switches for the left side (the windows that work) light up but the switches for the left (don't work) are dark. What sort of issue am I looking at here?

The car is a 1984 300SD W126.120

Thanks!
__________________
In the Garage:
'84 300SD, 85K "The Princess"
2011 BMW 328I XDrive, DD
Reply With Quote
  #2  
Old 04-24-2010, 10:16 AM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
I have the same issue on the passenger side. I can hear the rear wanting to move and decided it's the sliding jaw that needs replacement. The front door window however, doesn't make any noise, even after I replaced the switch.
__________________
83 SD

84 CD
Reply With Quote
  #3  
Old 04-24-2010, 10:21 AM
Registered User
 
Join Date: Sep 2004
Posts: 8,340
Quote:
Originally Posted by Tom Wing View Post
...the switches for the left side (the windows that work) light up but the switches for the left (don't work) are dark. What sort of issue am I looking at here?
Generalized directional confusion; hopefully transient in nature.

Have you verified that the console switch for the non-working windows is actually connected? Other than that, there is no relation between the LED operation and the switch functionality.
Reply With Quote
  #4  
Old 04-24-2010, 02:25 PM
Certified Moron
 
Join Date: Apr 2010
Posts: 44
I'm going to check that later today, interesting. Could this mean the switches need to be replaced? Neither makes any noise at all. (right hand side)
__________________
In the Garage:
'84 300SD, 85K "The Princess"
2011 BMW 328I XDrive, DD
Reply With Quote
  #5  
Old 04-24-2010, 04:48 PM
Diesel911's Avatar
Registered User
 
Join Date: Sep 2007
Location: Long Beach,CA
Posts: 22,091
There is threads and posts on taking apart the Switches and cleaning the contact points and crud that gets inside.
__________________
84 300D, 82 Volvo 244Gl Diesel
Reply With Quote
  #6  
Old 04-24-2010, 07:45 PM
69shovlhed's Avatar
Registered User
 
Join Date: Apr 2010
Location: Sterling, VA.
Posts: 286
it seems on the rear windows, if 1 switch is gummed up, both the front and rear switches will have the same malfunction. i changed the motor on rr window, during testing the motor would not turn if i pressed either switch in the down direction. cleaned out the front switch and now both switches work fine. console switch was full of gunk and filth, used a very fine scotch brite pad to clean the little contacts. i'd try that first.
__________________
1984 300TD "MAX" 303K+ still going...
fast '70 Chevelle 200k+
home built Shovelhead chopper
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page