Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-14-2010, 12:43 AM
Registered User
 
Join Date: May 2003
Location: Boonville Indiana
Posts: 2,342
Need Help With AC-1983-300SD

I jumpered the AC Clutch straight from the battery and a small open wire box under the passenger side of the brake booster started to smoke and got very hot and then the blower quit working and will not come on now even when heat is on. Which relay could have over heated.. What is that open wire box for? It has exposed wiring inside it.. any help will be appreciated.. Jim
__________________
James A. Harris
Reply With Quote
  #2  
Old 06-14-2010, 12:52 AM
big dog 2's Avatar
ejgolfnten
 
Join Date: Feb 2005
Location: Elk Grove, Ca
Posts: 206
Blower

Sure it was not the little coffin looking box next to the shock tower on driver's side? That is the little strip fuse for the blower! Cost a few dollars for the fuse at the stealership. You can jump it with a plain wire but you should use the rated fuse!
__________________


1989 300E

2005 Acura TL

2011 Hyundai Elantra Limited

Swing hard! Take chances!
Reply With Quote
  #3  
Old 06-14-2010, 12:54 AM
79Mercy's Avatar
Registered User
 
Join Date: Mar 2008
Location: Florida
Posts: 4,128
Sounds like you burned up the blower resistor. The resistor is that metal box with the exposed coiled wires inside.
__________________
1985 300TD Turbo Euro-wagon
1979 280CE 225,200 miles
1985 300D Turbo 264,000 miles
1976 240D 190,000 miles
1979 300TD 220,000

GONE but not forgotten
1976 300D 195,300 miles
1983 300D Turbo 175,000 miles

http://i42.photobucket.com/albums/e3...e485-1-2-1.jpg
Reply With Quote
  #4  
Old 06-14-2010, 10:57 AM
JamesDean's Avatar
Electrical Engineer
 
Join Date: Apr 2005
Location: NE Ohio
Posts: 4,987
It sounds as if somehow you toasted the fuse for the blower motor. I believe this is a 80amp fuse attached to the back of the firewall just in front of the passenger side of the brake booster. I believe its 80amps...

I'm not really sure how you toasted it though. According to the FSM the clutch isnt directly connected to the blower motor...unless it backfed into the "electronic unit for temperature control" and did something there....

http://imgur.com/WweHH.png (sorry for the rotation issue)
__________________
Cruise Control not working? Send me PM or email (jamesdean59@gmail.com). I might be able to help out.
Check here for compatibility, diagnostics, and availability!

82 300SD 145k
82 300SD 265k
87 420SEL 230k
89 420SEL 210k
89 560SEL 118k
90 300SE 262k RIP 5/25/2010
90 560SEL 154k
91 300D 2.5 Turbo. 241k
93 190E 3.0 235k
93 300E 195k
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page