Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 02-05-2012, 01:40 AM
Biodiesel300TD's Avatar
|3iodiesel300T|)
 
Join Date: Dec 2004
Location: Albany, OR
Posts: 4,845
I've had good success with replacing the K1 spring with the kit from the dealer, like $13 a year ago. I also tried using a K1 spring kit to replace the K2 in my it helped a little but not a whole lot. I think I'd go for the Superior Shift Kit. I think you get more option for adjustment from those kits.
Here is my thread about my 2-3 and 3-4 flare.

3-4 flaring shift.
__________________
Andrew
'04 Jetta TDI Wagon
'82 300TD ~ Winnie ~ Sold
'77 300D ~ Sold
Reply With Quote
  #17  
Old 02-05-2012, 01:52 AM
SpecialDelivery's Avatar
SWFL Benz Clubbin...
 
Join Date: Jun 2011
Location: Cape Coral, FL
Posts: 393
very cool...thanks dude...you just confirmed my suspicions....I'm going to go ahead and order the superior kit..what can it hurt? worst case I have new spring for the rebuilder!! thanks for the link!
__________________
-SpecialDelivery
1985 300CD Silver/Blue H&R Suspension (Sold, still cryin over that)
1982 300SD Silver/Blue '85 OM617 (Sold)
1982 300D - Blue/Blue (Sold)
Reply With Quote
  #18  
Old 02-18-2012, 08:47 PM
SpecialDelivery's Avatar
SWFL Benz Clubbin...
 
Join Date: Jun 2011
Location: Cape Coral, FL
Posts: 393
Pressures up to spec - flares are gone!

FYI Everyone following...

While my modulator WAS holding vac, I couldnt get more than 25 psi with the pin cranked all the way in. So I ordered one. I pulled the modulator to see if the pin was broken, it wasnt. It was oozing a rust colored liquid from under the black cap.



I installed a new modulator (febi/biltstien) and pin which had a longer base as well as overall length.



Then I hooked up the pressure rig, and it was (miraculously) reading at 42 psi at idle, dead on. Quite amazed I didnt have to adjust it.


I test drove it and the 3 to 4 flare is gone, still a slight on the 2 to 3...so I adjusted the VCV to put only 10" to the modulator at idle. Still a slight flare, which went away when the car warmed up.

BTW the modulator (from Fastlane, came with the o-ring seal and the rubber cap, no need to buy extras)

At this point the 2 to 3 is firm, clunks a little and I cant feel 3 to 4 at all.

I plan on tinkering with the VCV a little more but am quite happy that the problem is "resolved" and I dont need to rebuild the trans.

I'm debating on if I should install the "Superior Transmissions Shift Correction" spring kit I bought now or maybe at next fluid change or maybe sell it?

As always your thoughts, comments and ideas are appreciated!
__________________
-SpecialDelivery
1985 300CD Silver/Blue H&R Suspension (Sold, still cryin over that)
1982 300SD Silver/Blue '85 OM617 (Sold)
1982 300D - Blue/Blue (Sold)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page