Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-02-2013, 06:48 PM
Registered User
 
Join Date: Oct 2013
Posts: 3
Heat/ac help

A friend of mine has a diesel 1987 sdl and it needed a ac evaporator. So I put the evaporator in and everything went smooth. My problem is that I wen to test the heat and ac and I am having problems. The heat doesn't get hot and only comes out of the defrost no matter what button I use. Now when I kick it over I ac it will work wherever I put it. What could I have messed up??


After messing with it for a
Little bit I couldn't get the blower to shut off no matter what button I hit. I had to turn the key off. Any help would be helpful
Reply With Quote
  #2  
Old 10-03-2013, 12:33 AM
vstech's Avatar
DD MOD, HVAC,MCP,Mac,GMAC
 
Join Date: Mar 2006
Location: Mount Holly, NC
Posts: 25,832
it could be the push button unit, (pbu) take it out, and open it up, and look at the bottom of the circuit board... if the solder joints have white circles on them, it needs to be reflowed. if it has burns on it, you may have a damaged aux pump...
__________________
John HAUL AWAY, OR CRUSHED CARS!!! HELP ME keep the cars out of the crusher! A/C Thread
"as I ride with my a/c on... I have fond memories of sweaty oily saturdays and spewing R12 into the air. THANKS for all you do!

My drivers:
1987 190D 2.5Turbo
1987 190D 2.5Turbo
1987 190D 2.5-5SPEED!!!

1987 300TD
1987 300TD
1994GMC 2500 6.5Turbo truck... I had to put the ladder somewhere!
Reply With Quote
  #3  
Old 10-03-2013, 08:40 AM
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 2,941
Assuming the climate control functions worked before you took the dash apart, double check the following:

- Both cables plugged firmly into the PBU, and the left and right cables are not confused (not sure if they are keyed but just checking)

- Vacuum present at solenoid manifold under dash and all hoses hooked up

- Solenoid manifold plugged in

- Fuse F7 good, that is the source of power for the PBU/mono valve/aspiration blower/aux pump
__________________
2014 ML350 Bluetec (wife's DD)
2008 ML320 CDI (Kids college DD)
1998 E300DT (my DD)
1987 300TD (eternal project, I'm in too deep to quit now)
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #4  
Old 10-04-2013, 01:14 AM
Registered User
 
Join Date: Oct 2013
Posts: 3
I got heat. Car was low on coolant. I am new to this car but the blower turns off everytime after about 10 seconds of turning the switch off. Is that normal? I can still only get heat out of the defrost and not the two middle vents.
Reply With Quote
  #5  
Old 10-04-2013, 07:29 AM
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 2,941
That sounds like a vacuum side problem to me. If you have no vacuum at the 7 port manifold on the passenger side behind the glove box, then the PBU can't control the flaps, and it defaults into safe mode. Safe mode is max heat and all air out the defroster and blower on max.

Online service manuals for this car are free at startekinfo.com, look for chassis 126.
__________________
2014 ML350 Bluetec (wife's DD)
2008 ML320 CDI (Kids college DD)
1998 E300DT (my DD)
1987 300TD (eternal project, I'm in too deep to quit now)
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #6  
Old 10-04-2013, 08:40 AM
Registered User
 
Join Date: Oct 2007
Location: Greater Metropolitan Beaverdam VA
Posts: 1,472
The center vents

are active only in ac modes. If the vacuum controls are operating correctly, you will never get heat from them.

Sounds like your hvac is working fine.
Reply With Quote
  #7  
Old 10-04-2013, 02:39 PM
1984 300SD
 
Join Date: Feb 2007
Location: Vancouver BC
Posts: 588
A question for the Raccoon.
I always have some air coming through the defrost vents, even when air conditioning.
This reduces the flow from the proper vents. Is this a leaking vacuum pod?
Question 2. The AC compressor clutch snaps on when I select defrost.
Is this a setting problem or a shot button control box?
Thanks
__________________
1984 300SD turbo 126
"My true love"

God made me an atheist and who am I to question His wisdom
Reply With Quote
  #8  
Old 10-04-2013, 05:33 PM
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 2,941
Question 1, it could either be the pod going bad or the foam rubber deteriorated on the edge of the flap. The result is the same, the defrost flap won't seal shut.

Question 2, The compressor will normally be engaged for defrost at above freezing temperatures. This is so that the air directed at the window can be dehumidified. You need to get the dew point of the discharged air below the temperature of the glass or it will fog up on the inside.
__________________
2014 ML350 Bluetec (wife's DD)
2008 ML320 CDI (Kids college DD)
1998 E300DT (my DD)
1987 300TD (eternal project, I'm in too deep to quit now)
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #9  
Old 10-05-2013, 07:40 AM
Registered User
 
Join Date: Oct 2007
Location: Greater Metropolitan Beaverdam VA
Posts: 1,472
answer

what he said
Reply With Quote
  #10  
Old 10-05-2013, 02:09 PM
1984 300SD
 
Join Date: Feb 2007
Location: Vancouver BC
Posts: 588
Thank you gentlemen for your prompt and learned reply.
Where is that door that needs to needs re foamed and can it be accessed easily?
If a pod witch one?
Thanks
__________________
1984 300SD turbo 126
"My true love"

God made me an atheist and who am I to question His wisdom
Reply With Quote
  #11  
Old 10-05-2013, 02:46 PM
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 2,941
The defrost pod and door I believe on your car can only be accessed by removing the dash.

Best bet is to check out the online service manual, it has a very detailed description of the operation of the ac system and where all the doors and pods are.

startekinfo.com, click on MB Workshop Resources on the left side, page through until you find Chassis 126 manuals.
__________________
2014 ML350 Bluetec (wife's DD)
2008 ML320 CDI (Kids college DD)
1998 E300DT (my DD)
1987 300TD (eternal project, I'm in too deep to quit now)
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #12  
Old 10-05-2013, 08:41 PM
Registered User
 
Join Date: Oct 2013
Posts: 3
Thanks for the replies guys. I am going to look at what you guys said tomorrow. Thanks again and I'll let you guys know what I find.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 07:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page