Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-19-2013, 04:45 PM
Registered User
 
Join Date: Apr 2011
Location: SF, CA, USA
Posts: 931
engine temperature maxing out at 70 C...?

even after vigorous driving my cluster only indicates an engine temp of about 150 F. i checked the block with an infrared thermometer, and sure enough, 68 C. on this basis i think the sensor and gauge are working. getting up to temperature i have no questions about, i have just read so many posts about temperatures north of 90 C that this low reading confuses me.

my (W126) radiator fan appears to run nonstop. would a failed viscous clutch have this effect on temperature, or is something else likely to be afoot? do i actually have a problem?

thanks for any tips.

__________________
'77 240D, 504H, OM617.952, etc.
Reply With Quote
  #2  
Old 11-19-2013, 04:48 PM
Registered User
 
Join Date: Jul 2004
Location: Barrington, RI
Posts: 5,640
Bad thermostat is a good possibility.
__________________
06 E320 CDI "Benson", Platinum Blue, 180k mi, Stage 1 tune
06 E320 CDI "Rutherford", Black, 151k mi, Stage 1 tune
91 300D "Otis", Smoke Silver, 132k mi

19 Honda CR-V EX 10k mi
Thirteen other MB's owned and sold
1961 Very Tolerant Wife
Reply With Quote
  #3  
Old 11-19-2013, 04:48 PM
toomany MBZ's Avatar
Registered User
 
Join Date: Nov 2006
Location: central Va
Posts: 7,820
^ Agreed.
__________________
83 SD

84 CD
Reply With Quote
  #4  
Old 11-19-2013, 05:06 PM
Registered User
 
Join Date: Apr 2011
Location: SF, CA, USA
Posts: 931
thank you, off i go to replace the thermostat.
__________________
'77 240D, 504H, OM617.952, etc.
Reply With Quote
  #5  
Old 11-19-2013, 06:16 PM
jay_bob's Avatar
Control Freak
 
Join Date: Oct 2011
Location: Columbia, SC
Posts: 3,678
Be very very careful with the bolts, they have a nasty habit of breaking off with little provocation.
__________________
The OM 642/722.9 powered family
2014 ML350 Bluetec (wife's DD)
2013 E350 Bluetec (my DD)
2008 ML320 CDI (Older sonís DD)
2008 E320 Bluetec (Younger son's DD)

1998 E300DT sold to TimFreeh
1987 300TD sold to vstech
----------
gone but living on
1983 240D (body to greazzer, engine to t walgamuth)
Reply With Quote
  #6  
Old 11-19-2013, 07:33 PM
KarTek's Avatar
<- Ryuko of Kill La Kill
 
Join Date: Jun 2007
Location: Bahama/Eno Twp, NC
Posts: 3,258
On your second note, a viscous coupled fan always spins but the degree of coupling to the engine varies based on the temperature of the air coming through the radiator.
__________________
-Evan


Benz Fleet:
1968 UNIMOG 404.114
1998 E300
2008 E63


Non-Benz Fleet:
1992 Aerostar
1993 MR2
2000 F250
Reply With Quote
  #7  
Old 11-19-2013, 07:35 PM
Registered User
 
Join Date: Apr 2011
Location: SF, CA, USA
Posts: 931
very good, that was an easy fix. the only hiccup was figuring out that my thermostat housing was original to the chassis, so i had to reuse the old O-ring instead of the brand new gasket with the stub protrusion. i took the opportunity to reroute another heater hose and spill coolant all over my alternator. happy day!

so, now it gets up to 90ish C much more quickly, and i am more happy too. i was incorrectly assuming that the thermostat opening temperature was much lower than it actually is (80 C). thanks folks!
__________________
'77 240D, 504H, OM617.952, etc.
Reply With Quote
  #8  
Old 11-19-2013, 07:36 PM
Registered User
 
Join Date: Apr 2011
Location: SF, CA, USA
Posts: 931
wow KarTek, i see. thank you. then i will assume that it works until i find out otherwise.
__________________
'77 240D, 504H, OM617.952, etc.
Reply With Quote
  #9  
Old 11-19-2013, 08:27 PM
Registered User
 
Join Date: Nov 2013
Location: northern georgia
Posts: 16
do u have a brand and part number off that thermostat? i ordered one for my car ( wont get past 70) but the one sent was not correct ...
Reply With Quote
  #10  
Old 11-19-2013, 11:02 PM
Registered User
 
Join Date: Apr 2011
Location: SF, CA, USA
Posts: 931
hi trudge, i bought it from pelican parts. they have several from different brands, but as far as i can tell, the main difference is whether they have the old or new style of gasket (does the vernet one come with both?). the one i got was wahler brand.

__________________
'77 240D, 504H, OM617.952, etc.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 11:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page