Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-06-2019, 07:01 PM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,964
Car been sitting a year, Video of me trying to start it.

Little over a year of sitting, attempt at first start. 500,000k engine.

https://youtu.be/ERdeIuMh9-E

Also, looks like the pass rear hydraulic strut blew, judging by the puddle left by that wheel mark in the ground, several other good sized leaks as well. I guessing rear main, trans cooler lines.

Anyone have a strut laying around?









Attached Thumbnails
Car been sitting a year, Video of me trying to start it.-img_20190206_173149469_resize.jpg   Car been sitting a year, Video of me trying to start it.-img_20190206_173138118_resize.jpg   Car been sitting a year, Video of me trying to start it.-img_20190206_173334945_resize.jpg   Car been sitting a year, Video of me trying to start it.-img_20190206_173403537_resize.jpg  
Reply With Quote
  #2  
Old 02-06-2019, 07:17 PM
Registered User
 
Join Date: Mar 2008
Location: CT
Posts: 282
My 83 cd sat for a few years and I'd start it maybe once or twice a year. Put in a battery, glow once, and it woukd always fire up, much to the chagrin of my son, as I had said when it doesn't run he could have it.
__________________
95 E300D working out the kinks
77 300D, 227k, station car
83 300CD 370k, gone away
89 190E 2.6- 335k, no more
79 VW FI Bus- 145k miles, summer driver
59 VW Beetle ragtop- 175k miles
12 VW Jetta- 160k miles
Reply With Quote
  #3  
Old 02-07-2019, 06:33 AM
ngarover's Avatar
Registered User
 
Join Date: Oct 2010
Location: Northern Georgia
Posts: 1,964
Quote:
Originally Posted by my83300cd View Post
My 83 cd sat for a few years and I'd start it maybe once or twice a year. Put in a battery, glow once, and it woukd always fire up, much to the chagrin of my son, as I had said when it doesn't run he could have it.
So, he STILL doesn't have it I'm guessing...

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:15 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page