Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help



Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-07-2019, 08:09 PM
Jareb's Avatar
Registered User
 
Join Date: Apr 2007
Location: Florida
Posts: 210
Sunroof Wind Flap

1985 300TD,
The "wind deflector" on my sunroof does not pop up when the sunroof is opened. The small arms are attached properly. The flap just lays flat. Is there a spring that is broken or dislodged? Something else? I can lift it up with my hand but it doesn't stay up. Is this repairable or are there replacements available from MB?
Thanks
John

__________________
1985 300TDT
2013 E350 Bluetec

Last edited by Jareb; 09-07-2019 at 08:51 PM.
Reply With Quote
  #2  
Old 09-08-2019, 07:18 AM
optimusprime's Avatar
Trevor Hadlington
 
Join Date: May 2014
Location: Worcestershire in England
Posts: 1,386
W123 or w124 ? would help to know what model your talking about .
Reply With Quote
  #3  
Old 09-08-2019, 07:56 AM
optimusprime's Avatar
Trevor Hadlington
 
Join Date: May 2014
Location: Worcestershire in England
Posts: 1,386
This post is on the forum archive posted by sharebilly date 2018 .search for - Sun roof Wind Deflector I read that the deflector is flexible and you bend it in the centre to remove it from the pivot brackets on each end looking at the same time as to its location in the pivot brackets
Reply With Quote
  #4  
Old 09-08-2019, 09:06 AM
Registered User
 
Join Date: Apr 2004
Location: Chicago
Posts: 198
Although not likely, you may wish to verify you have the correct deflector for your wagon.

I had the same problem in my 85 wagon and would have to manually operate the deflector.

Got tired of that exercise and discovered a deflector for a W126 had been installed somewhere along the way. From what I remember 10+ years ago the W126 deflector could be made to fit, but it was binding in some way.

Put in a deflector from a W123 parts wagon and no problems since.
Reply With Quote
  #5  
Old 09-08-2019, 04:01 PM
Jareb's Avatar
Registered User
 
Join Date: Apr 2007
Location: Florida
Posts: 210
Quote:
Originally Posted by optimusprime View Post
W123 or w124 ? would help to know what model your talking about .
W123 85 TD Wagon
__________________
1985 300TDT
2013 E350 Bluetec
Reply With Quote
  #6  
Old 09-08-2019, 11:39 PM
Registered User
 
Join Date: Jun 2006
Location: Southeast
Posts: 1,768
Not sure, but....

Not sure about the older models but on my W124 it's all wzywig (what you see is what you get). Simply look at how it goes up/down. Move it with your fingers. Lube all the joints with the very light Mercedes grease (which is VERY expensive) or other light grease you can get from NAPA in a small squeeze tube for $6 or so.

The problem is probably dirt that's preventing it from working right so clean the entire area with a Q-tip, then lube it.

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:02 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page