Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-24-2002, 07:43 PM
carrotsandbeets
Guest
 
Posts: n/a
Angry 300sd instrument panel and rear tail light don't work

i have a 1981 300 sd that blows the fuse for the right rear tail light/instrument panel lights everytime i turn on the headlights. also the oil pressure gauge doesn't work--it jumps all the way up everytime the key is turned on. have disconnected the rear tail lights at the left harness junction and the fuse still burns out when the light switch is turned on. so the problem is not at the point of the taillights. any ideas? thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:59 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page