Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-24-2003, 05:57 PM
Registered User
 
Join Date: Mar 2003
Location: Los Angeles, CA
Posts: 445
vacuum pump and brake booster

Several months ago I bought a 1982 300D turbo (W123). I've taken care of a host of minor problems but got stumped on the vacuum pump. Let me run through my findings and my suggested fixes and hopefully someone reading this can help:

After replacing a few pneumatic lock components I now have a leak free lock system (per my vacuum tester). The problem is that the brakes feel under power assisted and the door locks stop functioning after a few hours with the engine off.

I measured the vacuum pump as 17" Hg with the booster hose plugged and the rest of the hoses plugged. This isolates the system to just the pump. This seemed too low as I was expecting 20-23"Hg per my memory reading through other postings. With the brake booster conected the vacuum is only 11" Hg and the gauge needle is flickering. From this I decided both the vacuum pump and the booster needed work.

I bought a $50 rebuild kit for my pison air pump. I took the pump off the car and inspected the rocker bearing which looked perfect so I went ahead and rebuilt the pump with the 3 new check valves, pison seal and used all the other parts in the kit (see attached photo). After reinstalling the pump I now have no vacuum! This time instead of taking off the pump from the car I just took off the pump cover. It looks like the pison seal that sits over the o-ring sliped off the piston. I cleaned everything and put back the old (but undamaged) piston seal back on. Again 0" vacuum. I have now ordered a new (or rebuilt?) vacuum pump for just over $200. I've rebuilt many hydraulic and some pneumatic systems in the past and never had so much trouble/bad luck.

I assume things will be much better with the new vac pump except my wallet. Has anyone had a similar problem rebuilding one of these piston vacuum pumps?

I will probably still have a brake booster problem with a vacuum leak. Can the booster be repaired with new seals, grommets, etc? Does the entire booster ever ned to be replaced. How do I determine what needs replacing?

Thanks for your help,
Elliot
Attached Thumbnails
vacuum pump and brake booster-piston-vacuum-pump-rebuild-kit.jpg  
Reply With Quote
  #2  
Old 03-27-2003, 07:13 PM
Registered User
 
Join Date: Mar 2003
Location: Los Angeles, CA
Posts: 445
Brake booster and vacuum pump

Sadly for me no one stepped in to give me any advise. Here is some follow up info and questions. I was unsuccessful rebuilding the vacuum pump as it was unable to pull a vacuum after reinstalling. Maybe i scored the center hole of the pison where the threaded rod comes through. It suprises me that the center hole is sealed with a metal (steel or was it aluminum?) washer topped with a nut, how air tight can that be? Instead I ended up paying $204 for a new one and I'm now getting 23" Hg instead of the 17" when i first tested the old pump isolated form the rest of the vacuum system.

My brake booster is also a problem as it is unable to hold any vacuum. I picked up a booster for $75 at a local MB salvage yard today. It tested OK in the yard with my Mityvac --no noticeable leak after 15 minutes of waiting. I had no idea if these things can be rebuilt and I can't afford to disable the car during the day as it is one of our daily drivers so I went for a used one.

Does anyone know if the o-ring between the master cylinder and the booster should be replaced? Also how should the inside of the booster be cleaned without damaging the diaphram. There is no obvious fluid but appears to have a light film of oil in there. I saw the salvage guy struggling under the dask to remove it and he simply cut the break lines to move the master cylinder out of the way. I guess i'll have to disconnect the brake lines to the master cyl to replace the booster? Any tricks to make this job easier/quicker?

Thanks
Reply With Quote
  #3  
Old 03-27-2003, 11:44 PM
Moderator
 
Join Date: Jul 2001
Location: Old Lyme, Connecticut
Posts: 3,596
Elliot,

I hope someone with some specific experience pipes up soon, as I can only offer some pretty generic, simple advice on the question of replacing the O-ring. Replace it. These are usually cheap, subject to wear and aging. They may visually appear alright, but aging can change (reduce or eliminate) the elasticity of the ring, which will change its function, usually making it non-functional.

I am not aware of the condition of the inside of the booster, but if it is raw steel, without any paint, I would expect it would need a little oil coating as a corrosion inhibitor. If the inside is painted, there is likely no need for an oil film, but if the paint is not being attacked by the film, it is probably not detrimental.

Once again, I hope some other members pipe up with some useful information. Good luck, Jim
__________________
Own:
1986 Euro 190E 2.3-16 (291,000 miles),
1998 E300D TurboDiesel, 231,000 miles -purchased with 45,000,
1988 300E 5-speed 252,000 miles,
1983 240D 4-speed, purchased w/136,000, now with 222,000 miles.
2009 ML320CDI Bluetec, 89,000 miles

Owned:
1971 220D (250,000 miles plus, sold to father-in-law),
1975 240D (245,000 miles - died of body rot),
1991 350SD (176,560 miles, weakest Benz I have owned),
1999 C230 Sport (45,400 miles),
1982 240D (321,000 miles, put to sleep)
Reply With Quote
  #4  
Old 03-27-2003, 11:53 PM
Registered User
 
Join Date: Mar 2003
Location: Los Angeles, CA
Posts: 445
Thanks Jim,
I will definetely change the o-ring ($4 at the dealer). the inside is hardly "contaminated" and may be just what you said--corrosion protection. Can't wait to get real power brakes back.
Reply With Quote
  #5  
Old 03-23-2004, 01:53 AM
romansek
 
Join Date: Jun 2003
Location: Dallas, Tx
Posts: 188
Problem with vacuum pump rebuild kit

The problem with vacuum pump rebuilt kit is, that blue seals for the check valves are difference thickness than original. When I install new seals and screw top cover the valves played. After installing old seals vacuum pump works fine and vacuum is 23" Hg.

Roman
------------
83 300D 222K
Reply With Quote
  #6  
Old 03-25-2004, 01:38 AM
Registered User
 
Join Date: Mar 2003
Location: Los Angeles, CA
Posts: 445
Hard to believe and I've never read this from anyone else who did a V-pump rebuild. I thought I had done something wrong when i tried rebuilding mine. I wonder if the aftermarket seal kit is the problem and not the kit from MB.
__________________
1972 450SL
1982 300D Turbo
Reply With Quote
  #7  
Old 03-25-2004, 02:07 PM
Registered User
 
Join Date: May 2003
Location: Boonville Indiana
Posts: 2,342
Oil In Booster

The oil in the booster usually comes from a bad vacuum pump, if it is dirty oil and a film will not hurt you..if more just wipe it out and spray with brake cleaner and wipe...their is no easy way to remove the booster...you need to remove the master cylinder and then get inside the car to remove the nuts from the 4 booster bolts...But uaually the booster causes a hard brake condition..the brake pedal will be very hard to activate...it might just be the seal between master cylinder and the booster..check vacuum at end of hose where it goes into booster...Jim
__________________
James A. Harris
Reply With Quote
  #8  
Old 04-21-2004, 10:13 AM
JenTay's Avatar
Registered User
 
Join Date: Dec 2003
Posts: 555
to remove the booster, how do you get to the four bolts from inside the car?

does the dash have to come out? or could i just do it with the instrument cluster out?
__________________
Jennifer
90 350sdl
Reply With Quote
  #9  
Old 04-21-2004, 06:47 PM
Wes Bender's Avatar
Retired User
 
Join Date: Mar 2001
Location: Alpine, AZ / Green Valley, AZ
Posts: 733
Jen -

You can get at the bolts if you take the lower panel off. You don't need to pull the dash or instrument cluster. You might wind up laying upside down on a reclined driver's seat to do this if you can't comfortably reach them from the open door. But then you are probably more flexible than my 67 year old body (sigh).

Cheers,
Wes


P.S. How was golf in FL? We gonna get a report?
Reply With Quote
  #10  
Old 04-21-2004, 07:41 PM
Tymbrymi's Avatar
Klatta Klatta
 
Join Date: Jan 2004
Location: Olive Branch, MS
Posts: 616
I had vacuum problems and when I rebuilt the pump I had absoloutely no vacuum as you did.... I just figured it was due to never doing anything mechanical two months prior (the white car was a tremendous learning experience I ended up just buying the pump like you did, worked like a charm!

When you are going through the fun ordeal of changing the brake booster also make sure to flush all your brake lines with fresh brake fluid. There are many reasons to do this, and it is also mentioned in the MB manual as an annual preventitive maintenance item. That and it just makes sense to change fluid that cames out of the bottle clear, and has turned black in your resevoir and lines!!

Best of luck in your project

John
'79 300SD
Reply With Quote
  #11  
Old 04-22-2004, 11:11 AM
Registered User
 
Join Date: Apr 2004
Posts: 72
Rebuilding the pump

I have a 1980 300D with the older-style single diaphragm vacuum pump. It needed to be rebuilt because of a tear in the rubber diaphragm. I rebuilt it on the engine by just removing the cover, and I did it at night. The two little circle check valves that I also replaced were positioned differently I think, and I put them back in facing the wrong way (again night time). When I tried the car there was no vacuum. Then I had to go back in and take all the stuff out of the way again to get to the check valves to put them in the right direction. Once they were put in the right direction, I got 25" vacuum.

I don't know the exact setup for the piston vacuum pump, but maybe some of those check valves are the same, and perhaps they were put back in facing the wrong direction(s). That could possibly explain vacuum before and absolutely no vacuum after.
Reply With Quote
  #12  
Old 04-22-2004, 11:18 AM
Tymbrymi's Avatar
Klatta Klatta
 
Join Date: Jan 2004
Location: Olive Branch, MS
Posts: 616
Its been over a year since my last attempt, but I believe the cover of the piston style has the proper indentations or lack thereof to prevent you from putting the check valves in wrong. I also took pictures as I did the job, and I put mine back in the same way they came out!

John
'79 300SD
Reply With Quote
  #13  
Old 04-22-2004, 11:34 AM
Registered User
 
Join Date: Sep 2003
Location: Back in Colorado for now
Posts: 1,313
Quote:
Originally posted by Tymbrymi
Its been over a year since my last attempt, but I believe the cover of the piston style has the proper indentations or lack thereof to prevent you from putting the check valves in wrong. I also took pictures as I did the job, and I put mine back in the same way they came out!

John
'79 300SD
That's correct. The cover keeps you from installing any other way than the right way.

Just rebuilt two of these units and ended up using the old seals for the three internal check valves. Used a "seal swell" stuff on them and then hi-temp gasket sealer to make it permanent.
__________________
1984 300D Turbo - 4-speed manual conversion, mid-level resto

1983 300D - parts car

1979 300TD Auto - Parts car.

1985 300D Auto - Wrecked/Parts.


=========================

"If you don't know where you are going, any road will get you there". Lewis Carrol
Reply With Quote
  #14  
Old 04-22-2004, 06:08 PM
kmaysob's Avatar
Registered User
 
Join Date: Nov 2003
Location: mesa az
Posts: 1,673
so has anyone been able to rebuild it with the kit? not having to use gasket maker or use the original seals.
__________________
have no worries.....President Obama swears "If you like your gun, you can keep it
Reply With Quote
  #15  
Old 04-22-2004, 08:01 PM
lietuviai's Avatar
Registered User
 
Join Date: Mar 2003
Location: SW WA
Posts: 5,741
Hey Tom, what is that seal swell stuff you're talking about? Is it just WD-40? I've used WD-40 in the past to give new life to some old seals by soaking them in it overnight. It worked great on some 40+ year old rubber seals that I could no longer get.
__________________
DJ


84 300D Turbodiesel 190K with 4 speed manual sold in 03/2012
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page