Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Diesel Discussion

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-23-2003, 11:40 PM
Registered User
 
Join Date: Sep 2003
Location: Back in Colorado for now
Posts: 1,313
Weird Odometer Problem

Had the cluster all apart, everything checked fine, no gears missing, broken, etc., when the odometer gears/numbers are manually turned, the trip meter turns fine.

On the bench it "appeared" to clock/count up with turning the speedo cable, but now with it in the dash and hooked up to the tranny, speedo works fine, but no odometer or trip?

It's still up on blocks, but the tranny output is where the cable is driven and I get plenty of speedo action with engine running and in gear?

Anyone else had this same problem?
__________________
1984 300D Turbo - 4-speed manual conversion, mid-level resto

1983 300D - parts car

1979 300TD Auto - Parts car.

1985 300D Auto - Wrecked/Parts.


=========================

"If you don't know where you are going, any road will get you there". Lewis Carrol
Reply With Quote
  #2  
Old 10-24-2003, 12:46 AM
Kyle Blackmore's Avatar
Mostly Harmless
 
Join Date: Sep 2001
Location: almost beyond Hope...B.C.
Posts: 897
Have you tried resetting the trip meter ? try jiggling it when you push it in, maybe something got out of alignment in there , good luck.
__________________
1985 380SE- 160,000km 'Blistu' - Sold
1988 300CE- Eva,my garage mistress
2007 R350 4matic- The Black Pearl
2011 Ford Ranger-Work truck
1974 25' Trojan Sea Raider- 'Grannyknot'
2002 215 cm Atomic DH skis- Canadian SDH record holder, 175.5km/h- Vars 2010
Reply With Quote
  #3  
Old 10-24-2003, 07:43 AM
shoe's Avatar
Senior Member
 
Join Date: Jun 2000
Location: Baton Rouge, LA.
Posts: 583
Pull it and send it to Steve Brotherton at Contenintal Imports. I THINK for $80.00 to $100.00 bucks they will have it working like new.
__________________
Keith Schuster
2006 E350 98K miles
2013 Ford Explorer 15K miles
Reply With Quote
  #4  
Old 10-24-2003, 09:16 AM
Registered User
 
Join Date: Jan 2002
Posts: 18,354
Search the posts and you will find that the odometers fail because the gear pressed to the shaft begins to spin on the shaft. You'll find the procedure for fixing it in those posts
__________________
1977 300d 70k--sold 08
1985 300TD 185k+
1984 307d 126k--sold 8/03
1985 409d 65k--sold 06
1984 300SD 315k--daughter's car
1979 300SD 122k--sold 2/11
1999 Fuso FG Expedition Camper
1993 GMC Sierra 6.5 TD 4x4
1982 Bluebird Wanderlodge CAT 3208--Sold 2/13
Reply With Quote
  #5  
Old 10-24-2003, 07:25 PM
Stevo's Avatar
Registered User
 
Join Date: Apr 2002
Location: NW WA
Posts: 6,285
http://www.mbz.org/info/articles/instruments/ I think this is the one
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 09:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page